activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Dillon (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AMQ-1185) ActiveMQ 4.1 has crept in some Java 5 APIs, which prevent it from being used on Java 1.4 JVMs
Date Fri, 02 Mar 2007 04:00:12 GMT

    [ https://issues.apache.org/activemq/browse/AMQ-1185?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_38632
] 

Jason Dillon commented on AMQ-1185:
-----------------------------------

Ugh... appears there are a bunch of test failures with the above... though very hard to find
them due to all of the output from the tests :-(

But they are failing with things like:

{noformat}
Test set: org.apache.activemq.spring.SpringTest
-------------------------------------------------------------------------------
Tests run: 5, Failures: 0, Errors: 4, Skipped: 0, Time elapsed: 11.035 sec <<< FAILURE!
testSenderWithSpringXml(org.apache.activemq.spring.SpringTest)  Time elapsed: 0.58 sec  <<<
ERROR!
java.lang.NoClassDefFoundError: java/util/concurrent/ExecutionException
        at org.apache.activemq.store.DefaultPersistenceAdapterFactory.createJournal(DefaultPersistenceAdapterFactory.java:224)
        at org.apache.activemq.store.DefaultPersistenceAdapterFactory.getJournal(DefaultPersistenceAdapterFactory.java:132)
        at org.apache.activemq.store.DefaultPersistenceAdapterFactory.createPersistenceAdapter(DefaultPersistenceAdapterFactory.java:70)
        at org.apache.activemq.broker.BrokerService.createPersistenceAdapter(BrokerService.java:1320)
        at org.apache.activemq.broker.BrokerService.getPersistenceAdapter(BrokerService.java:631)
        at org.apache.activemq.broker.BrokerService.deleteAllMessages(BrokerService.java:888)
        at org.apache.activemq.broker.BrokerService.start(BrokerService.java:387)
        at org.apache.activemq.transport.vm.VMTransportFactory.doCompositeConnect(VMTransportFactory.java:113)
        at org.apache.activemq.transport.vm.VMTransportFactory.doConnect(VMTransportFactory.java:52)
        at org.apache.activemq.transport.TransportFactory.doConnect(TransportFactory.java:43)
        at org.apache.activemq.transport.TransportFactory.connect(TransportFactory.java:77)
        at org.apache.activemq.ActiveMQConnectionFactory.createTransport(ActiveMQConnectionFactory.java:230)
        at org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:245)
        at org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:214)
        at org.apache.activemq.ActiveMQConnectionFactory.createConnection(ActiveMQConnectionFactory.java:161)
        at org.apache.activemq.spring.SpringConsumer.start(SpringConsumer.java:49)
        at org.apache.activemq.spring.SpringTest.assertSenderConfig(SpringTest.java:154)
        at org.apache.activemq.spring.SpringTest.testSenderWithSpringXml(SpringTest.java:91)
{noformat}

Which shows there is more Java 5 stuff lingering around... perhaps in some other dependency?

> ActiveMQ 4.1 has crept in some Java 5 APIs, which prevent it from being used on Java
1.4 JVMs
> ---------------------------------------------------------------------------------------------
>
>                 Key: AMQ-1185
>                 URL: https://issues.apache.org/activemq/browse/AMQ-1185
>             Project: ActiveMQ
>          Issue Type: Bug
>    Affects Versions: 4.1.1
>            Reporter: Jason Dillon
>            Priority: Blocker
>         Attachments: AMQ-1185.diff
>
>
> A few bits of Java 5 API has made it into the AMQ 4.1 branch, which prevent 4.1 from
being used on Java 1.4 JVMS.
> Apache Geronimo v1.2 needs AMQ 4.1 running on Java 1.4.
> So far I don't see anything major which prevents AMQ 4.1 from being compiled with Java
1.4... only a few minor changes to keep compatibility.  The alternative is of course to use
the retrotranslator-maven-plugin to generate 1.4 compatible jars for each module (the new
retrotranslator:translate-project makes this very easy to use, includes attaching jdk14 artifacts).
> But IMO, that would just add more complexity for AMQ 4.1 when only a few simple changes
will allow the it to be native 1.4... though you folks might consider using retrotranslator:translate-project
for trunk to create 1.4 compatible jars for the new AMQ (> 4.1.x) bits.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message