activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: Does ActiveMQ 4.2 client jar support Java 1.4?
Date Thu, 01 Feb 2007 13:01:48 GMT
On 1/31/07, Miing <miing@yahoo.com> wrote:
> Hi,
>
> I've read in the forum that release 4.2 will require Java 5 to run.
>
> Will it be the same for the client jars?

Yes

> Reason being that I have an application running in 1.4 that will require the
> bug fixes in ActiveMQ 4.2.
>
> It will be great if the client jars can still run under Java 1.4

Any particular reason why you are stuck on 1.4?

FWIW it should be easy to run retrotranslator on the jars to produce
1.4 compatible jars
http://retrotranslator.sourceforge.net/

Or just install the retrotranslator JIT to use any Java 5 code on Java 1.4
http://retrotranslator.sourceforge.net/#jit

-- 

James
-------
http://radio.weblogs.com/0112098/

Mime
View raw message