activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hiram Chirino" <hi...@hiramchirino.com>
Subject Re: PLEASE HELP ASAP: C#/.NET implementation CRASHES on Connection Startup
Date Tue, 06 Feb 2007 17:27:05 GMT
I'd like for folks to give some feed back.. But I think it's close to
a 1.0 release state.

On 2/6/07, James Strachan <james.strachan@gmail.com> wrote:
> Its probably worth tagging the .Net code now eh?
>
> On 2/6/07, Hiram Chirino <hiram@hiramchirino.com> wrote:
> > It's actually easy to explain.  the .NET client was updated to start
> > using version 2 of the openwire protocol which was still under
> > development.  At the point the .NET client was working fine.  As
> > version 2 of the protocol evolved, the .NET client stopped working.
> > We did the final release of ActiveMQ 4.1 which effectively freezes
> > version 2 of the protocol but we never got back to updating the .NET
> > client to bring in the final v2 protocol changes.  (Which is silly
> > that we waited this long since bringing in the changes is a simple as
> > running a code generation command).
> >
> > But now that the v2 of protocol is frozen and the .NET client has been
> > updated for it, it don't think we should see anymore problems on this
> > front for a while (that is until we start v3 of the protocol).
> >
> > Regards,
> > Hiram
> >
> > On 2/6/07, sparky2708 <daa82@columbia.edu> wrote:
> > >
> > > Hiram,
> > > Thank you. Thank you. Just checked out the source code from SVN trunk and it
> > > seems like it started working -- at least all of my basic tests seem like
> > > they are working now. Thanks!
> > >
> > > Just a side question, do you know how this could have happened -- there is
> > > no way the code could have passed the NUNIT tests that are setup for testing
> > > the C# NMS client. When are those tests run?
> > >
> > >
> > >
> > > Hiram Chirino wrote:
> > > >
> > > > Good news.. The C# started working for me against the 4.1.x release as
> > > > soon as I regenerated the openwire v2 marshallers.  I've checked in
> > > > the updated marhsallers so if you get an update from SVN it should
> > > > work.
> > > >
> > > > I've also tested it against ActiveMQ 4.0.x (which uses the openwire v1
> > > > marshallers) and it also seem to work fine.
> > > >
> > > > On 2/1/07, sparky2708 <daa82@columbia.edu> wrote:
> > > >>
> > > >> Sorry, for posting this twice but I wasn't sure where to post it.
I
> > > >> posted
> > > >> this in the "User" forum but didn't get a reply. If you could
> > > >> please,please,please address this issue as I am completely stuck with
the
> > > >> C#
> > > >> NMS client.
> > > >>
> > > >> THE ISSUE:
> > > >> A few days ago I checked out the latest C#/.NET code using svn as
per the
> > > >> instructions on the website. Revision: "Checked out revision 501459".
I
> > > >> built the code without any problems but am now trying to run it in
> > > >> VS2005.
> > > >> From the debugger it looks like the error occurs when I call
> > > >> _connection.Start()  Here is my code:
> > > >>
> > > >> private IConnection _connection;
> > > >> private string JMS_URL = "tcp://localhost:61616";
> > > >>
> > > >> public MessageManager() {
> > > >>         IConnectionFactory connectionFactory = new ConnectionFactory(new
> > > >> Uri(JMS_URL));
> > > >>         _connection = connectionFactory.CreateConnection();
> > > >>         _connection.ExceptionListener += new
> > > >> ExceptionListener(_connection_ExceptionListener);
> > > >>         _connection.Start();
> > > >> }
> > > >>
> > > >>  void _connection_ExceptionListener(Exception exception)
> > > >>     {
> > > >>         Console.WriteLine("Received Exception from JMS: " + exception);
> > > >>     }
> > > >>
> > > >>
> > > >>
> > > >>
> > > >> In the console window I get:
> > > >>
> > > >> Received Exception from JMS: System.NullReferenceException: Object
> > > >> reference
> > > >> not
> > > >>  set to an instance of an object.
> > > >>    at ActiveMQ.Transport.WireFormatNegotiator.OnCommand(ITransport
> > > >> sender,
> > > >> Comma
> > > >> nd command)
> > > >>    at ActiveMQ.Transport.Tcp.TcpTransport.ReadLoop()
> > > >> Received Exception from JMS: System.NullReferenceException: Object
> > > >> reference
> > > >> not
> > > >>  set to an instance of an object.
> > > >>    at ActiveMQ.Transport.WireFormatNegotiator.OnCommand(ITransport
> > > >> sender,
> > > >> Comma
> > > >> nd command)
> > > >>    at ActiveMQ.Transport.Tcp.TcpTransport.ReadLoop()
> > > >> Received Exception from JMS: System.NullReferenceException: Object
> > > >> reference
> > > >> not
> > > >>  set to an instance of an object.
> > > >>    at ActiveMQ.Transport.WireFormatNegotiator.OnCommand(ITransport
> > > >> sender,
> > > >> Comma
> > > >> nd command)
> > > >>    at ActiveMQ.Transport.Tcp.TcpTransport.ReadLoop()
> > > >> Received Exception from JMS: System.NullReferenceException: Object
> > > >> reference
> > > >> not
> > > >>  set to an instance of an object.
> > > >>    at ActiveMQ.Transport.WireFormatNegotiator.OnCommand(ITransport
> > > >> sender,
> > > >> Comma
> > > >> nd command)
> > > >>    at ActiveMQ.Transport.Tcp.TcpTransport.ReadLoop()
> > > >>
> > > >> --
> > > >> View this message in context:
> > > >> http://www.nabble.com/PLEASE-HELP-ASAP%3A-C--.NET-implementation-CRASHES-on-Connection-Startup-tf3155472.html#a8750152
> > > >> Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.
> > > >>
> > > >>
> > > >
> > > >
> > > > --
> > > > Regards,
> > > > Hiram
> > > >
> > > > Blog: http://hiramchirino.com
> > > >
> > > >
> > >
> > > --
> > > View this message in context: http://www.nabble.com/PLEASE-HELP-ASAP%3A-C--.NET-implementation-CRASHES-on-Connection-Startup-tf3155472.html#a8826805
> > > Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.
> > >
> > >
> >
> >
> > --
> > Regards,
> > Hiram
> >
> > Blog: http://hiramchirino.com
> >
>
>
> --
>
> James
> -------
> http://radio.weblogs.com/0112098/
>


-- 
Regards,
Hiram

Blog: http://hiramchirino.com

Mime
View raw message