activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From EricGeode <geodera...@yahoo.com>
Subject Re: [VOTE RESULT] Does ActiveMQ 4.2 client jar support Java 1.4?
Date Tue, 20 Feb 2007 22:52:24 GMT

Has anyone actually got this to work?

I tried this (retrofitted apache-activemq-4.1.0-incubator.jar), but still
cannot run under 1.4. ClassNotFound exception in a Native method.

This is the code I'm trying to run:
		BrokerService broker = new BrokerService();
		broker.setUseJmx(true);
		broker.addConnector("tcp://localhost:61616");   // <-- This triggers the
error
		broker.start();

My company creates software for other companies. We cannot control what Java
version they run.

Eric
...snip
Any particular reason why you are stuck on 1.4?

FWIW it should be easy to run retrotranslator on the jars to produce
1.4 compatible jars
http://retrotranslator.sourceforge.net/

...snip
-- 
View this message in context: http://www.nabble.com/Does-ActiveMQ-4.2-client-jar-support-Java-1.4--tf3152081s2354.html#a9072172
Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.


Mime
View raw message