activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shoaib Akhtar (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AMQ-1054) XA recover fails for 4.0.1
Date Tue, 28 Nov 2006 14:34:02 GMT
    [ https://issues.apache.org/activemq/browse/AMQ-1054?page=comments#action_37582 ] 
            
Shoaib Akhtar commented on AMQ-1054:
------------------------------------

Hi James,
In the meanwhile the url mentioned by Guy Pardon really shows that the exception occurs only
when there is no transaction to recover
http://mail-archive.objectweb.org/jotm/2006-11/msg00002.html

> XA recover fails for 4.0.1
> --------------------------
>
>                 Key: AMQ-1054
>                 URL: https://issues.apache.org/activemq/browse/AMQ-1054
>             Project: ActiveMQ
>          Issue Type: Bug
>         Environment: Java, JDK 1.4, Windows, Atomikos TransactionsEssentials for the
JTA/XA part
>            Reporter: Guy Pardon
>         Attachments: pom.xml
>
>
> XAResource.recover seems to fail for 4.x of ActiveMQ:
> ERROR IN RECOVERY [thread: SimpleAsyncTaskExecutor-3] on: 06-11-16 08:43:35,152 
> [Lorg.apache.activemq.command.DataStructure; [thread: SimpleAsyncTaskExecutor-3] on:
06-11-16 08:43:35,152 
> at: org.apache.activemq.TransactionContext.recover(TransactionContext.java:508) [thread:
SimpleAsyncTaskExecutor-3] on: 06-11-16 08:43:35,152 
> at: com.atomikos.datasource.xa.XATransactionalResource.recover(Unknown Source) [thread:
SimpleAsyncTaskExecutor-3] on: 06-11-16 08:43:35,152 
> at: com.atomikos.datasource.xa.XATransactionalResource.endRecovery(Unknown Source) [thread:
SimpleAsyncTaskExecutor-3] on: 06-11-16 08:43:35,152 
> at: com.atomikos.icatch.imp.TransactionServiceImp.recover(Unknown Source) [thread: SimpleAsyncTaskExecutor-3]
on: 06-11-16 08:43:35,153 
> at: com.atomikos.datasource.xa.XATransactionalResource.setRecoveryService(Unknown Source)
[thread: SimpleAsyncTaskExecutor-3] on: 06-11-16 08:43:35,153 
> at: com.atomikos.icatch.system.Configuration.addResource(Unknown Source) [thread: SimpleAsyncTaskExecutor-3]
on: 06-11-16 08:43:35,153 
> at: com.atomikos.jms.QueueConnectionFactoryBean.checkSetup(Unknown Source) [thread: SimpleAsyncTaskExecutor-3]
on: 06-11-16 08:43:35,153 
> at: com.atomikos.jms.QueueConnectionFactoryBean.createQueueConnection(Unknown Source)
[thread: SimpleAsyncTaskExecutor-3] on: 06-11-16 08:43:35,153 
> at: com.atomikos.jms.QueueConnectionFactoryBean.createConnection(Unknown Source) [thread:
SimpleAsyncTaskExecutor-3] on: 06-11-16 08:43:35,153 
> Also see http://www.atomikos-support.com/forums/viewtopic.php?t=351 (where I borrowed
this stack trace from). We have seen similar things in other applications that tried to use
ActiveMQ. I think this is a class cast error in ActiveMQ...
> With 3.1 there is no problem. 

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://issues.apache.org/activemq/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message