activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kelly Campbell" <kelly.a.campb...@gmail.com>
Subject Re: Switching to ActiveMQ 4.2 to Java 5???
Date Thu, 16 Nov 2006 10:16:52 GMT
+1 for 1.5, but perhaps keep the client-side 1.4 compatible?

On 11/15/06, James Strachan <james.strachan@gmail.com> wrote:
>
> +1.
>
> We should switch to Java 5 for compilation and for the default release
> (since the concurrent stuff is  faster & more bug free on Java 5) but
> maybe provide a retrotranslator version of the jars for those who
> can't move JVM.
>
> i.e. build on Java 5 only - but allow deployments on 1.4
>
> On 11/15/06, Hiram Chirino <hiram@hiramchirino.com> wrote:
> > Hi folks,
> >
> > How do you guys feel about switching the minimum run time requirement
> > for ActiveMQ 4.2 to be Java 5??  I'm itching to do this since Java 5
> > has a much better set of concurrent implementation.
> >
> > We can keep the 4.1.x branch alive as the Java 1.4 compatible version.
> >  Also I have a feeling that once we switch to Java 5, someone will
> > figure out how to use retrotranslator to make our Java 5 binaries also
> > run on Java 1.4.  But I doubt anybody will make any efforts to look
> > into that until we actually jump to Java 5.
> >
> > So what do you say?  Shall we switch ??
> >
> > --
> > Regards,
> > Hiram
> >
> > Blog: http://hiramchirino.com
> >
>
>
> --
>
> James
> -------
> http://radio.weblogs.com/0112098/
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message