activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adrian Co (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (AMQ-1024) Exclusive Consumer Losing a Message
Date Fri, 10 Nov 2006 07:22:02 GMT
     [ https://issues.apache.org/activemq/browse/AMQ-1024?page=all ]

Adrian Co resolved AMQ-1024.
----------------------------

    Fix Version/s: 4.1
       Resolution: Fixed

Hi,

I've fixed this in trunk rev 473219.

Maybe you can try the latest version in trunk. :)

> Exclusive Consumer Losing a Message
> -----------------------------------
>
>                 Key: AMQ-1024
>                 URL: https://issues.apache.org/activemq/browse/AMQ-1024
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 4.0.1
>         Environment: Windows XP
>            Reporter: M H
>         Assigned To: Adrian Co
>             Fix For: 4.1
>
>
> In my test, I have two consumers, one is set to be an exclusive consumer.  The exclusive
consumer is started last.  If a producer sends 10 messages, one message goes to the non-exclusive
consumer while the other 9 messages go to the exclusive consumer.  I would think all the messages
should go to the exclusive consumer even though it is started after the non-exclusive consumer.
 Both consumers were started before the producer sent any messages.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://issues.apache.org/activemq/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message