activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bas van Beek (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AMQ-1028) AMQ Stops dispatching messages after a period of time without errors/warnings
Date Fri, 10 Nov 2006 13:09:02 GMT
    [ https://issues.apache.org/activemq/browse/AMQ-1028?page=comments#action_37410 ] 
            
Bas van Beek commented on AMQ-1028:
-----------------------------------


Well at the moment it does bring the system "down" in a way...

one consumer subscribed (with ack:client) on topic FOO behaves badly by not correctly consuming
it's messages (not acknowledging them).

Effect... the messaging system's RAM usage is increasing until it's depleted of available
space and all subscribers (also the ones on topic BAR) stop
receiving messages. 

Now imagine the badly behaving consumer being killed without closing the TCP transport like
it should and the effect is the system is still not processing
messages until that subscription times out (I'm not sure if it even does this... I have the
distinct feeling I saw lingering subscriptions even when the connection was
closed correctly... but I'll check that next week when back at the office again...

in my opinion it should never be possible to let a consumer lock up the system like this...


> AMQ Stops dispatching messages after a period of time without errors/warnings
> -----------------------------------------------------------------------------
>
>                 Key: AMQ-1028
>                 URL: https://issues.apache.org/activemq/browse/AMQ-1028
>             Project: ActiveMQ
>          Issue Type: Bug
>    Affects Versions: 4.0.2
>         Environment: Os: Ubuntu Linux i386 - Java: J2RE SE 1.5.0_08-b03
>            Reporter: Bas van Beek
>            Priority: Critical
>             Fix For: 4.0.2
>
>
> The ActiveMQ stand alone server seems to stop dispatching messages to topics after a
period of time. 
> New clients can connect... new subscriptions to topics can be made... no errors are shown...
messages are just not sent... including to and from the new clients...
> No errors or warnings can be found in the ActiveMQ.log (even in debug mode)
> JConsole doesn't show the new messages coming in (EnqueueCount doesn't change)
> Stomp Protocol is used exclusively

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://issues.apache.org/activemq/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message