activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hiram Chirino" <hi...@hiramchirino.com>
Subject Re: [activemq-cpp] It now compiles under cygwin
Date Tue, 03 Oct 2006 18:25:07 GMT
On 10/3/06, Bish, Tim <Tim.Bish@sensis.com> wrote:
> There are some issues using the cygwin compiler, mainly that the tests
> won't pass as the sockets all break for strange reasons.  Although Mingw
> isn't much better in this regard.  It did also seem to have trouble

Yeah.. winsock sux. :)

> compiling under cygwin on various machines for reason that I could never
> explain (oh the joy of using Cygwin).  I've got no problem using it so
> long as it works :)

I hope we get it at that stage soon!

>
> I tried running the autogen.sh in my cygwin bash shell and this is what
> I get
>
> /usr/share/aclocal/pstoedit.m4:7: warning: underquoted definition of
> AM_PATH_PSTOEDIT
>   run info '(automake)Extending aclocal'
>   or see
> http://sources.redhat.com/automake/automake.html#Extending-aclocal
> /usr/share/aclocal/libmcrypt.m4:17: warning: underquoted definition of
> AM_PATH_LIBMCRYPT

This is a warnning I used to get with cppunit too.. It can be safely
ignored but if you want to get rid of the warnning, send me what you
have in the /usr/share/aclocal/libmcrypt.m4 file at line 17 and I'll
send you back what you need to update it with.

> aclocal:configure.ac:43: warning: macro `AM_PROG_LIBTOOL' not found in
> library

Run cygwin setup and install libtool

> aclocal:configure.ac:57: warning: macro `AM_PATH_CPPUNIT' not found in
> library

Run cygwin setup and install cppunit

> configure.ac:52: error: possibly undefined macro: AM_PROG_LIBTOOL
>       If this token and others are legitimate, please use
> m4_pattern_allow.
>       See the Autoconf documentation.
> configure.ac:66: error: possibly undefined macro: AM_PATH_CPPUNIT
> autoreconf-2.5x: /usr/bin/autoconf-2.5x failed with exit status: 1
>
> >
> > Hey activemq-cpp folks.
> >
> > activemq-cpp should now compile fine under cygwin.  You may need to
> > install all the right versions of autoconf and automake.
> >
> > Tim.. any chance I could convince you to switch to cygwin instead?  I
> > tried as hard as I could to use mingw under automake but I could not
> > find the right combination of packages needed to get everything happy.
> >
> > The automake systems seems to be working well across several different
> > systems now, it supports running the unit tests and generating the
> > docs so I think we should  switch to it as soon as possible.  (the
> > only system that I have not tested was Solaris)
>
> This may present some problems for people on older Solaris machines such
> as Solaris 8, as there aren't really any distributions on newer versions
> of the tools being maintained anymore.  It looks like it might be okay
> on my Solaris 10 machine, but I'd have to install CPPUNIT first.
>
> We are using CPP_UNIT 1.11.6 btw.
>
> >
> > --
> > Regards,
> > Hiram
> >
> > Blog: http://hiramchirino.com
>


-- 
Regards,
Hiram

Blog: http://hiramchirino.com

Mime
View raw message