activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pawel Niewiadomski (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AMQ-991) ActiveMQ 4.0.1 crashes when using client from trunk.
Date Tue, 24 Oct 2006 10:29:02 GMT
    [ https://issues.apache.org/activemq/browse/AMQ-991?page=comments#action_37268 ] 
            
Pawel Niewiadomski commented on AMQ-991:
----------------------------------------

I updated libraries today using trunk and still server crashes.

> ActiveMQ 4.0.1 crashes when using client from trunk.
> ----------------------------------------------------
>
>                 Key: AMQ-991
>                 URL: https://issues.apache.org/activemq/browse/AMQ-991
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: NMS (C# client)
>            Reporter: Pawel Niewiadomski
>
> I tried today to use C# client from trunk agains ActiveMQ 4.0.1 server. This caused server
to die totally. Following error message was shown by server:
> {noformat}
> Exception in thread "ActiveMQ Transport: tcp:///127.0.0.1:1699" java.lang.Illega
> lArgumentException: Invalid version: 2, could not load org.apache.activemq.openwire.v2.MarshallerFactory
>         at org.apache.activemq.openwire.OpenWireFormat.setVersion(OpenWireFormat.java:329)
>         at org.apache.activemq.openwire.OpenWireFormat.renegociatWireFormat(OpenWireFormat.java:569)
>         at org.apache.activemq.transport.WireFormatNegotiator.onCommand(WireFormatNegotiator.java:100)
>         at org.apache.activemq.transport.InactivityMonitor.onCommand(InactivityMonitor.java:122)
>         at org.apache.activemq.transport.TransportSupport.doConsume(TransportSupport.java:87)
>         at org.apache.activemq.transport.tcp.TcpTransport.run(TcpTransport.java:143)
>         at java.lang.Thread.run(Thread.java:595)
> Caused by: java.lang.ClassNotFoundException: org.apache.activemq.openwire.v2.MarshallerFactory
>         at org.apache.activemq.util.ClassLoading.loadClass(ClassLoading.java:104)
>         at org.apache.activemq.openwire.OpenWireFormat.setVersion(OpenWireFormat.java:327)
>         ... 6 more
> {noformat}
> I then used ActiveMQ 4.0.2 server and it worked. Isn't that client should automatically
negotiate protocol with server? Why server after this error dies totally? (new client connecting
were not handled at all, everything died).

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://issues.apache.org/activemq/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message