activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ngcutura <ngcut...@gmail.com>
Subject Re: Build fails with SVN checkout
Date Tue, 24 Oct 2006 21:21:46 GMT

Thanks, I did it and it works. I already use it for development but I wanted
to build my own AMQ from Maven and it fails. Right now, I build from Eclipse
only the modules I actually work on and then use AMQ snapshot with my
modules. 

However, I have another issue: activemq-core requires JDK 1.5 to build.
Build fails if I use J2SDK 1.4.2 
Is this expected? I can build activemq-jaas with 1.4.2 just fine.

Regards,
NGC


rajdavies wrote:
> 
> the command you need is mvn eclipse:eclipse - which will build the  
> eclipse .project file for you.
> 
> What I'd recommend (if your not already doing this) is:
> 
> 1. build activemq in a separate area from your eclipse workspace -  
> mvn install -Dmaven.test.skip=true
> 2. build all the eclipse projects - mvn eclipse:eclipse
> 3. ensure the M2_REPO variable is set in eclipse  to your maven repo  
> (usually located in your home directory - called .m2/repository).  
> Your can set the variable from the eclipse properties dialog (ADD  
> variable)
> 4. Use Eclipse  -> File -> Import -> import existing properties into  
> workspace - to import the bits of activemq you want
> 
> apologies if you already know how to do this!
> 
> cheers,
> 
> Rob
> 
> On 12 Oct 2006, at 12:44, ngcutura wrote:
> 
>>
>> Hi,
>>
>> I am using Eclipse. When I do as you suggested from the command  
>> line, I get
>> "Build Successful". When start Eclipse again, I have the same  
>> errors as
>> before.
>>
>> Any suggestions?
>>
>> Regards,
>> NGC
>>
>>
>> rajdavies wrote:
>>>
>>> try changing directory to activemq/activemq-openwire-generator - and
>>> do mvn install from there - then the build should work from the top
>>> directory.
>>> Please note - there's some failing test cases at the moment - just
>>> fixing ...
>>>
>>> cheers,
>>>
>>> Rob
>>> On 12 Oct 2006, at 09:28, ngcutura wrote:
>>>
>>>>
>>>> Hi,
>>>>
>>>> Here are the errors Maven reports. I have direct access to the
>>>> Internet, no
>>>> proxy. Where can I find the missing files for manual download?
>>>>
>>>> Regards,
>>>> NGC
>>>>
>>>> ...
>>>>
>>>> 12.10.06. 08.59.54 CEST: Missing:
>>>> ----------
>>>> 1) com.sun:tools:jar:1.4.2
>>>>
>>>>   Try downloading the file manually from the project website.
>>>>
>>>>   Then, install it using the command:
>>>>       mvn install:install-file -DgroupId=com.sun - 
>>>> DartifactId=tools \
>>>>           -Dversion=1.4.2 -Dpackaging=jar -Dfile=/path/to/file
>>>>
>>>>   Path to dependency:
>>>>   	1)
>>>> org.apache.activemq:activemq-openwire-generator:jar:4.1-incubator-
>>>> SNAPSHOT
>>>>   	2) com.sun:tools:jar:1.4.2
>>>>
>>>> ----------
>>>> 1 required artifact is missing.
>>>>
>>>> for artifact:
>>>> org.apache.activemq:activemq-openwire-generator-4.1-incubator-
>>>> SNAPSHOT.jar
>>>>
>>>> ...
>>>>
>>>>
>>>> 12.10.06. 09.54.13 CEST: Missing:
>>>> ----------
>>>> 1) com.sun:tools:jar:1.4.2
>>>>
>>>>   Try downloading the file manually from the project website.
>>>>
>>>>   Then, install it using the command:
>>>>       mvn install:install-file -DgroupId=com.sun - 
>>>> DartifactId=tools \
>>>>           -Dversion=1.4.2 -Dpackaging=jar -Dfile=/path/to/file
>>>>
>>>>   Path to dependency:
>>>>   	1)
>>>> org.apache.activemq:activemq-openwire-generator:jar:4.1-incubator-
>>>> SNAPSHOT
>>>>   	2) com.sun:tools:jar:1.4.2
>>>>
>>>> ----------
>>>> 1 required artifact is missing.
>>>>
>>>> for artifact:
>>>> org.apache.activemq:activemq-openwire-generator-4.1-incubator-
>>>> SNAPSHOT.jar
>>>>
>>>> ...
>>>>
>>>> 12.10.06. 10.06.18 CEST: Missing:
>>>> ----------
>>>> 1) com.sun:tools:jar:1.4.2
>>>>
>>>>   Try downloading the file manually from the project website.
>>>>
>>>>   Then, install it using the command:
>>>>       mvn install:install-file -DgroupId=com.sun - 
>>>> DartifactId=tools \
>>>>           -Dversion=1.4.2 -Dpackaging=jar -Dfile=/path/to/file
>>>>
>>>>   Path to dependency:
>>>>   	1)
>>>> org.apache.activemq:activemq-openwire-generator:jar:4.1-incubator-
>>>> SNAPSHOT
>>>>   	2) com.sun:tools:jar:1.4.2
>>>>
>>>> ----------
>>>> 1 required artifact is missing.
>>>>
>>>> for artifact:
>>>> org.apache.activemq:activemq-openwire-generator-4.1-incubator-
>>>> SNAPSHOT.jar
>>>>
>>>>
>>>> -- 
>>>> View this message in context: http://www.nabble.com/Build-fails-
>>>> with-SVN-checkout-tf2318351.html#a6772114
>>>> Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.
>>>>
>>>
>>>
>>>
>>
>> -- 
>> View this message in context: http://www.nabble.com/Build-fails- 
>> with-SVN-checkout-tf2318351.html#a6774651
>> Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.
>>
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Build-fails-with-SVN-checkout-tf2318351.html#a6981807
Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.


Mime
View raw message