activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wallaec Wong (JIRA)" <j...@apache.org>
Subject [jira] Created: (AMQ-975) Setting "time to live" to >0 fails delivery from linux to window
Date Fri, 13 Oct 2006 19:46:16 GMT
Setting "time to live" to >0 fails delivery from linux to window
----------------------------------------------------------------

                 Key: AMQ-975
                 URL: https://issues.apache.org/activemq/browse/AMQ-975
             Project: ActiveMQ
          Issue Type: Bug
          Components: JMS client
    Affects Versions: 4.0.1, 4.0
         Environment: Linux, window XP
            Reporter: Wallaec Wong


I found this problem on 4.0 and 4.0.1 running on Linux. 

Problem reproduction steps: 
1. start activemq server on a linux server 
2. start a consumer client on a window XP 
3. start a producer client on same linux machine, setting timeToLive to any value > 0 
4. consumer client will not receive any messages 

5. set the time to live to 0, the consumer client will receive messages, or 
6. set time to live to 0 or not, consumer client running on linux will receive messages too,
or 
7. no problem too if producer runs on xp and consumer runs on linux 

And apparently it does not really matter where the activemq server runs, linix or xp. 


-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://issues.apache.org/activemq/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message