activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Suvarna Raju Madhey (JIRA)" <j...@apache.org>
Subject [jira] Created: (AMQ-1018) Tomcat JVM hangs when it tried to get ConnectionFactory object
Date Tue, 31 Oct 2006 18:48:02 GMT
Tomcat JVM hangs when it tried to get ConnectionFactory object
--------------------------------------------------------------

                 Key: AMQ-1018
                 URL: https://issues.apache.org/activemq/browse/AMQ-1018
             Project: ActiveMQ
          Issue Type: Bug
    Affects Versions: 4.0.1
         Environment: Tomcat 5.5.9, Activemq 4.0.1
            Reporter: Suvarna Raju Madhey
            Priority: Critical
             Fix For: 4.0.2
         Attachments: StackTrace

I have deployed my application in Tomcat 5.5.9, which uses Activemq 4.0.1. 

To get ConnectionFactory I have written a method called getConnectionFactory.

Following way i am tring to lookup..
Context ctx = new InitialContext();
Context ctx2= (Context) initCtx.lookup("java:comp/env");
ConnectionFactory cf = (ConnectionFactory) ctx2.lookup("jms/ConnectionFactory");

3 iterations of start and stop works successfully. But when I start the application 4th time,
it executes Context ctx2 = (Context)initCtx.lookup("java:comp/env"); then it goes to next
line. After that it never returns ConnectionFactory. After I notice that the application hangs..

Please find the stack which i got by running "kill -3 <tomcat-process-pid>
 

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://issues.apache.org/activemq/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message