activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Hutt (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AMQ-765) ActiveMQ RA serialization issue on Glassfish
Date Fri, 06 Oct 2006 18:33:09 GMT
    [ https://issues.apache.org/activemq/browse/AMQ-765?page=comments#action_37120 ] 
            
Michael Hutt commented on AMQ-765:
----------------------------------

The same thing happens on oracle (oc4j) 10.1.3, except that I am using ActiveMQTopicConnectionFactory,
instead of the managed connection factory.
Same error, same line.

Details:
-I deploy the resource adapter exactly as it comes packaged in v4.0.1
-I'm using an external broker, running on the same machine.
-I create one topic connection factory
-I create one topic

In the code, the context lookups for the topics go through just fine (the objects are found),
but upon calling factory.createTopicConnection(), I get the NPE.  Setting UseInboundSession
to true lets this go through just fine, but I'm not writing a message driven bean, so this
doesn't help me out very much.


> ActiveMQ RA serialization issue on Glassfish
> --------------------------------------------
>
>                 Key: AMQ-765
>                 URL: https://issues.apache.org/activemq/browse/AMQ-765
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Connector
>    Affects Versions: 4.0, 4.0.1
>         Environment: Glassfish
>            Reporter: Chris Conrad
>
> I've been trying to work through an issue with a NullPointerException run using the JCA
1.5 resource adapter on Glassfish.  In the course of debugging, Siva from the Glassfish team
provided this information:
> "Thanks for trying out GlassFish. Since I have only the trace snippet above, I tried
to debug this problem by going through ActiveMQ RA's source available at https://svn.apache.org/repos/asf/incubator/activemq/trunk/activemq-ra/src/main/java/org/apache/activemq/ra/
> This is what I understand happens. Please correct me if there are errors. When ActiveMQConnectionFactory
[https://svn.apache.org/repos/asf/incubator/activemq/trunk/activemq-ra/src/main/java/org/apache/activemq/ra/ActiveMQConnectionFactory.java]
is created at the createConnectionFactory method of https://svn.apache.org/repos/asf/incubator/activemq/trunk/activemq-ra/src/main/java/org/apache/activemq/ra/ActiveMQManagedConnectionFactory.java,
the ConnectionManager is initialized to a *transient* variable "manager". Since ConnectionFactory
instances can be serialized/deserialized while publishing to JNDI (as is the case in Project
GlassFish), the connectionManager reference is lost and hence the NPE. The fix ideally should
be in the ActiveMQRA's code. You could copy me [sivakumart AT sun DOT com] while you are discussing
this with ActiveMQ, if you wish. If you still have any issues, please provide a copy of your
domain.xml [connector connection pool, resource configuratin information] and the entire trace
in server.log." 

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://issues.apache.org/activemq/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message