activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dhawan, Vikram \(LNG-DAY\)" <vikram.dha...@lexisnexis.com>
Subject RE: JMX inteface is not running on latest release of AMQ 4.0.1
Date Fri, 22 Sep 2006 22:08:49 GMT
I still have a old release on my computer 4.0-SNAPSHOT (4/18/2006), and
interesting thing is with the exactly same activemq.xml and on exactly
same computer JMX is working with that and not working with 4.0.1. 

I am not sure what's going on here.

Thanks!

Vik

-----Original Message-----
From: Dhawan, Vikram (LNG-DAY) [mailto:vikram.dhawan@lexisnexis.com] 
Sent: Friday, September 22, 2006 5:10 PM
To: activemq-dev@geronimo.apache.org
Subject: RE: JMX inteface is not running on latest release of AMQ 4.0.1

Hi Aaron,

Thanks for your input here I am attaching the activemq.xml I am using.
Please let me know if there is any change needed. This is the same
activemq.xml I was using for previous release and it worked fine. 

I am using Java 5.

Vik

-----Original Message-----
From: ammulder@gmail.com [mailto:ammulder@gmail.com] On Behalf Of Aaron
Mulder
Sent: Friday, September 22, 2006 2:39 PM
To: activemq-dev@geronimo.apache.org
Subject: Re: JMX inteface is not running on latest release of AMQ 4.0.1

I didn't have that problem in ActiveMQ 4.0.1.  Are you sure you have
<broker useJmx="true" in your config file?  Also, if you're running
under Java 5, you may be using the JMX environment from the JVM which
would prevent ActiveMQ from emitting the message about how its binding
JMX to port such-and-such (because it doesn't create it's own JMX
listener if it uses the JVM MBeanServer).  You can force ActiveMQ to
use its own JMX listener with the managementContext settings, if you
want to.

Thanks,
    Aaron

On 9/22/06, Dhawan, Vikram (LNG-DAY) <vikram.dhawan@lexisnexis.com>
wrote:
> Hi,
>
>
>
> I think this is a real problem; I looked over few times before I am
> posting it. In the activemq.xml I uncommented the managementContext
> section too.
>
>
>
> On my activemq console I don't see a message which used to be there
> saying that JMX connection be made.
>
>
>
> Thanks!
>
>
>
> Vik
>
>
>
>
>

Mime
View raw message