activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sepand M" <sepa...@gmail.com>
Subject Re: JAAS problems
Date Wed, 23 Aug 2006 16:48:24 GMT
One other thing I should add:

I am currently running using the provided activemq script and the main
method provided in activemq.console.Main.
A few days ago, I ran the same code using my own main method and
without the activemq script and it ran perfectly.

Any thoughts?

On 8/23/06, Sepand M <sepandm@gmail.com> wrote:
> Hi James,
>
> I don't, but I'm running off of an assembly build and I have
> apache-activemq-4.1-incubator-SNAPSHOT.jar on the class path. I've
> also confirmed that the classes not found (such as GroupPrincipal) are
> in the mentioned jar.
>
> - Sepand
>
> On 8/23/06, James Strachan <james.strachan@gmail.com> wrote:
> > Do you have the activemq-jaas.jar on your classpath?
> >
> > On 8/23/06, Sepand M <sepandm@gmail.com> wrote:
> > > Hi,
> > >
> > > I can't seem to get JAAS working.
> > > I've defined the login.config as shown on the site, but I get the
> > > following error once a connection comes in (the exception is thrown
> > > when lc.login is called in JaasAuthenticationBroker.java):
> > >
> > > javax.security.auth.login.LoginException: unable to find LoginModule
> > > class: org.apache.activemq.jaas.GroupPrincipal
> > >         at javax.security.auth.login.LoginContext.invoke(LoginContext.java:808)
> > >         at javax.security.auth.login.LoginContext.access$000(LoginContext.java:186)
> > >         at javax.security.auth.login.LoginContext$4.run(LoginContext.java:683)
> > >         at java.security.AccessController.doPrivileged(Native Method)
> > >         at javax.security.auth.login.LoginContext.invokePriv(LoginContext.java:680)
> > >         at javax.security.auth.login.LoginContext.login(LoginContext.java:579)
> > >         at org.apache.activemq.security.JaasAuthenticationBroker.addConnection(JaasAuthenticationBroker.java:76)
> > >         at org.apache.activemq.broker.BrokerFilter.addConnection(BrokerFilter.java:80)
> > >         at org.apache.activemq.broker.MutableBrokerFilter.addConnection(MutableBrokerFilter.java:90)
> > >         at org.apache.activemq.broker.AbstractConnection.processAddConnection(AbstractConnection.java:559)
> > >         at org.apache.activemq.broker.jmx.ManagedTransportConnection.processAddConnection(ManagedTransportConnection.java:83)
> > >         at org.apache.activemq.command.ConnectionInfo.visit(ConnectionInfo.java:120)
> > >         at org.apache.activemq.broker.AbstractConnection.service(AbstractConnection.java:228)
> > >         at org.apache.activemq.broker.TransportConnection$1.onCommand(TransportConnection.java:63)
> > >         at org.apache.activemq.transport.ResponseCorrelator.onCommand(ResponseCorrelator.java:92)
> > >         at org.apache.activemq.transport.TransportFilter.onCommand(TransportFilter.java:67)
> > >         at org.apache.activemq.transport.WireFormatNegotiator.onCommand(WireFormatNegotiator.java:123)
> > >         at org.apache.activemq.transport.InactivityMonitor.onCommand(InactivityMonitor.java:123)
> > >         at org.apache.activemq.transport.TransportSupport.doConsume(TransportSupport.java:88)
> > >         at org.apache.activemq.transport.tcp.SslTransport.doConsume(SslTransport.java:128)
> > >         at org.apache.activemq.transport.tcp.TcpTransport.run(TcpTransport.java:127)
> > >         at java.lang.Thread.run(Thread.java:595)
> > >
> > > As you may have noticed, the class missing is GroupPrincipal. This is
> > > because I changed login.config to use that class. I did the same thing
> > > using ActiveMQConnectionFactory and there were no problems (well, it
> > > obviously couldn't use it as a LoginModule, but it had no problem
> > > finding the class). It seems that it can't find classes within
> > > org.apache.activemq.jaas.
> > >
> > > Does anyone know what's going on?
> > >
> > > Regards,
> > > Sepand
> > >
> >
> >
> > --
> >
> > James
> > -------
> > http://radio.weblogs.com/0112098/
> >
>

Mime
View raw message