activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Naveen Rawat <nav...@in.effectsoft.com>
Subject Re: How to create a temporary Queue
Date Wed, 23 Aug 2006 13:24:49 GMT

Hi James,


> It sounds like your server is sending a response to a client which has
> already disconnected.


It seems the issue about the respond-back consumer not able to see the
temporary queue/topic even when its creator sender is in connection has been
faced in the past. The issue has been discussed here (I hav managed to get 2
of those) -

	"The initial receiver (reply back server) is hanging on to the message."
	http://www.nabble.com/Locked-messages-tf2115092.html#a5907342

	"The message sent to a temp topic  is never delivered to consumer."
	http://www.nabble.com/Flow-control-tf1539523.html#a4208304


What is discussed in the links is exactly my scenario. My receiver also goes
into sleep mode (to be restarted again) after receiving the first message.
As suggested in the above discussion links, the working becomes fine if
regular topics/queues are used which is exactly happening with me. This
issue remained unresolved in both the above links.

I think this issue has the cardinality to be taken seriously.
What do you say James.


	Thanks in Advance


With warm regards,
Navin


-- 
View this message in context: http://www.nabble.com/How-to-create-a-temporary-Queue-tf2145190.html#a5944413
Sent from the ActiveMQ - Dev forum at Nabble.com.


Mime
View raw message