activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sudhakar <sendtosu...@hotmail.com>
Subject CreateSession fails and remains in wait mode in C#
Date Thu, 17 Aug 2006 19:45:58 GMT

Hello,

I am trying to use the .Net Message Service
API(https://svn.apache.org/repos/asf/incubator/activemq/trunk/activemq-dotnet/) 
in C# to communicate to ACtive MQ. Using the following code i am able to
successfully connect to Activer MQ but when i am trying to create a session
using connection.CreatSession() method it goes in wait mode and nothing
happens after that 

IConnectionFactory factory = new ConnectionFactory(new
Uri("tcp://BldFriday:61613"));
            using (IConnection connection = factory.CreateConnection())
            {
                connection.Start();
                Console.WriteLine("Created a connection!" + connection );

                ISession session = connection.CreateSession();

                IDestination destination = session.GetQueue("FOO.BAR");
                Console.WriteLine("Using destination: " + destination);
                ................
                .............

In the Class FutureResponse there is a while loop in the  Response property
as the reponse object is null it loops in here and never exits the loop.

I am facing the same problem in Windows and Linux. 

If you come across this issue please help me to solve.

thanks 
Sudhakar R 
-- 
View this message in context: http://www.nabble.com/CreateSession-fails-and-remains-in-wait-mode-in-C--tf2123542.html#a5858227
Sent from the ActiveMQ - Dev forum at Nabble.com.


Mime
View raw message