activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "olivier benichou (JIRA)" <j...@apache.org>
Subject [jira] Created: (AMQ-885) setUseAsyncSend default value causes bad performance if the client and the server are not on the same machine
Date Sun, 20 Aug 2006 12:41:23 GMT
setUseAsyncSend default value causes bad performance if the client and the server are not on
the same machine
-------------------------------------------------------------------------------------------------------------

                 Key: AMQ-885
                 URL: https://issues.apache.org/activemq/browse/AMQ-885
             Project: ActiveMQ
          Issue Type: Bug
    Affects Versions: 3.2.2
         Environment: WINDOWS NT server 2003
            Reporter: olivier benichou


When creating ActiveMQConnectionFactory instance, one shall set UseAsyncSend attribute to
false,
otherwise performance are very poor if the server and the client are not running on the same
machine.

The question is : Is it normal to have to set UseAsyncSend to false if we want to have good
performance ?

	ActiveMQConnectionFactory factory = new ActiveMQConnectionFactory(brokerURL);
    	factory.setUseAsyncSend(false);

Thanks




-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://issues.apache.org/activemq/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message