activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron Mulder (JIRA)" <>
Subject [jira] Created: (AMQ-862) POM error means I can't use a dependency on 4.1-incubator-SNAPSHOT
Date Fri, 04 Aug 2006 18:42:23 GMT
POM error means I can't use a dependency on 4.1-incubator-SNAPSHOT

                 Key: AMQ-862
             Project: ActiveMQ
          Issue Type: Bug
    Affects Versions: 4.1
            Reporter: Aaron Mulder
            Priority: Critical

I'm trying to build jencks, which has a dependency on ActiveMQ 4.1-incubator-SNAPSHOT.  I
get the following unresolved dependencies:


What it's actually trying to download is:

Those are invalid versions.  When I asked about this on the maven IRC, I was told:

the problem is here:
In the dependencyManagement they're using, they have expressions for the versions.  Those
resolve to the current POM's (the one specifying the dependencies) version, instead of resolving
them as snapshots.  It's a common problem when using that expression for shortcuts.

It would be great if this could be fixed so that I could build jencks.  Thanks!

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:


View raw message