activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mittler, Nathan" <nathan.mitt...@sensis.com>
Subject RE:
Date Mon, 03 Jul 2006 13:08:17 GMT
Hi Naveen,
There are a couple of things that might be causing this.

1) The stomp frame ending characters have changed in recent versions of
AMQ.  AMQ now enforces that stomp frames end with \0\n for all commands.
If you have an older version of CMS, and a fairly new version of AMQ
(e.g. 4.0), they may not play nice together.

2) I have seen some deadlocking occur on compilers that don't support
the PTHREAD_MUTEX_RECURSIVE type for mutexes (the code checks
__USE_UNIX98 and __APPLE__ flags to make this determination.  CMS
requires recursive mutexes to work properly - it will deadlock
otherwise.

Regardless of what your particular problem is, I recommend downloading
and trying out the activemq-cpp code
(https://svn.apache.org/repos/asf/incubator/activemq/trunk/activemq-cpp/
).  It solves the mutex problem (since it doesn't use recursive mutexes)
and has been tested against AMQ 4.0.1 (it actually requires 4.0.1 or
greater).  

Give that a try and let me know how it goes.

Regards,
Nate

> -----Original Message-----
> From: Naveen Rawat [mailto:naveen@in.effectsoft.com] 
> Sent: Saturday, July 01, 2006 9:15 AM
> To: activemq-dev@geronimo.apache.org; user@activemq.codehaus.org
> Subject: 
> 
> Hi there..!! 
> 
>  
> 
> I was trying out CMS OPENWIRE C++ APIs on SUSE Linux 
> 10.0(Kernel release
> 2.6.13-15.8-default)
> Whenever I try to execute TestMain.cpp it gives the following 
> and goes into sleep mode. 
> 
> 
> Connecting to ActiveMQ broker...
> Opening socket to: 127.0.0.1 on port 61666 Sending command: 
> cmd.id = 1, corr.id = -1, type = CONNECTION_INFO Received 
> command: cmd.id = 0, corr.id = -1, type = WIRE_FORMAT_INFO 
> Received command: cmd.id = 1, corr.id = -1, type = BROKER_INFO 
> 
>  
> 
>  
> 
>  
> 
> 
> My AMQ Server is running as : 
> 
> ACTIVEMQ_HOME: /home/nrawat/incubator-activemq-4.0
> Loading message broker from: xbean:activemq.xml Created 
> MBeanServer with ID: da6bf4:10c2b32b38c:-8000:kuwix:1
> INFO  BrokerService                  - ActiveMQ 4.0 JMS 
> Message Broker 
> (localhost) is starting
> INFO  BrokerService                  - For help or more 
> information please 
> see: http://incubator.apache.org/activemq/
> RMIConnectorServer started at: 
> service:jmx:rmi://kuwix/jndi/rmi://localhost:1099/jmxrmi
> INFO  ManagementContext              - JMX consoles can connect to 
> service:jmx:rmi://kuwix/jndi/rmi://localhost:1099/jmxrmi
> INFO  JDBCPersistenceAdapter         - Database driver recognized: 
> [apache_derby_embedded_jdbc_driver]
> INFO  JournalPersistenceAdapter      - Journal Recovery 
> Started from: Active 
> Journal: using 5 x 20.0 Megs at: 
> /home/nrawat/incubator-activemq-4.0/activemq-data/journal
> INFO  JournalPersistenceAdapter      - Journal Recovered: 0 
> message(s) in 
> transactions recovered.
> INFO  TransportServerThreadSupport   - Listening for connections at: 
> tcp://kuwix:61666
> WARN  MulticastDiscoveryAgent        - brokerName not set
> INFO  TransportConnector             - Connector default Started
> INFO  TransportServerThreadSupport   - Listening for connections at: 
> tcp://kuwix:61633?wireFormat=stomp
> INFO  TransportConnector             - Connector stomp Started
> INFO  NetworkConnector               - Network Connector 
> default Started
> INFO  BrokerService                  - ActiveMQ JMS Message Broker 
> (localhost, ID:kuwix-2163-1151775977128-1:0) started 
> 
>  
> 
>  
> 
>  
> 
> Hearty Regards, 
> 
> Naveen Rawat
> 

Mime
View raw message