activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "amon.lei (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AMQ-361) duplicate delivery, already consumed messages are reconsumed after server restart
Date Wed, 19 Jul 2006 03:02:23 GMT
    [ https://issues.apache.org/activemq/browse/AMQ-361?page=comments#action_36587 ] 
            
amon.lei commented on AMQ-361:
------------------------------

resolved it .... 

 in customer , 

session = connection.createSession(true, Session.CLIENT_ACKNOWLEDGE);  
===>
session = connection.createSession(false, Session.CLIENT_ACKNOWLEDGE); 

true -> false

but i dont know "false" will link to anther problom or not....


> duplicate delivery, already consumed messages are reconsumed after server restart
> ---------------------------------------------------------------------------------
>
>                 Key: AMQ-361
>                 URL: https://issues.apache.org/activemq/browse/AMQ-361
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker, Message Store, JCA Container
>    Affects Versions: 4.0
>         Environment: windows xp, jdk 1.5, embedded activemq 3.1 broker, jboss 4.02, persistent
messages with  derby db.
>            Reporter: Gokturk Ozer
>             Fix For: 4.1
>
>         Attachments: 1.log
>
>
> I am running an embedded activemq broker inside jboss server, I send 1000 messages with
~10K size each to a queue, these messages are consumed by MDBs. After all the messages are
consumed, I check the queue via hermes, it also shows no message in the queue. Everything
works perfect up to this point. I observe the problem after I stop the jboss server. I connect
to derby database via networkserver, I still see some messages in activemq_msgs table. I shutdown
derby networkserver and start jboss again, I see from the log that some of the messages which
were consumed previously, are being consumed again. If I start the server without deploying
the MDB and check the queue via hermes, I see some but not all the messages which were consumed
previously still in the queue, before restart hermes was showing no messages. 

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://issues.apache.org/activemq/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message