activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "james strachan (JIRA)" <j...@apache.org>
Subject [jira] Created: (AMQ-815) generate a warning by default if a client connects via openwire using a different release version of the broker
Date Tue, 11 Jul 2006 16:06:51 GMT
generate a warning by default if a client connects via openwire using a different release version
of the broker
---------------------------------------------------------------------------------------------------------------

         Key: AMQ-815
         URL: https://issues.apache.org/activemq/browse/AMQ-815
     Project: ActiveMQ
        Type: Improvement

    Reporter: james strachan
     Fix For: 4.1


While we can be quite liberal in supporting backwards compatible clients, the default should
be to warn folks if they connect via different versions - as thats often an indication of
classpath issues.

Maybe have 3 options - lenient (try to work with anything), warning (just log warning on connection),
strict (disconnect non-similar version clients)

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   https://issues.apache.org/activemq/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message