activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Yaussy (JIRA)" <>
Subject [jira] Commented: (AMQ-523) vm:// connections don't show in jmx info (jconsole)
Date Thu, 15 Jun 2006 12:41:51 GMT
    [ ] 

Kevin Yaussy commented on AMQ-523:


Thanks for looking.  We have a monitoring GUI that we already had for our current Pub/Sub
(JMS-ish) environment.  When I saw that the jconsole was not showing the VM connections, I
was concerned how I could get to them for our existing GUI.  Since then, you guys added the
Subscription bean, which I discovered I could use as a backdoor to get the VM connections.
 So, for the moment we have a workaround.

I will wait until 4.2 for the more direct approach for this information.

Thanks again.

> vm:// connections don't show in jmx info (jconsole)
> ---------------------------------------------------
>          Key: AMQ-523
>          URL:
>      Project: ActiveMQ
>         Type: Improvement

>   Components: Broker
>     Versions: 4.0 M4
>     Reporter: Kevin Yaussy
>      Fix For: 4.2

> AMQ 4 M4
> I'm using embedded brokers, which service vm:// connections as well as tcp:// connections.
 The external connections show under the "Connection" area of the jmx management interface,
but the vm:// connections do not.  From a management standpoint, all connections are necessary
to monitor.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:

View raw message