activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "will gunadi (JIRA)" <>
Subject [jira] Commented: (AMQ-528) 4.0 M4 NullPointerException while shutting down
Date Sat, 24 Jun 2006 14:36:51 GMT
    [ ] 

will gunadi commented on AMQ-528:

Holger wrote:

> So it seems a proper shutdown of the Executor will solve this.

Is this something that can be done from the application code? 
or do I have to wait for the new version of the backport-*.jar? what's the ETA if I may ask?

I tried to use the backport MillisProvider but I can't get the JVM to see the class (ClassNotFoundException)
no matter where i put the backport*.jar file (I even tried it in tomcat's /shared/lib and
it still can't find the class).  Yet the class is there, albeit it looks like an inner class

Until Sun releases the next jvm after 1.5_06 for Linux, I don't have any other JVM to go to.

> 4.0 M4 NullPointerException while shutting down
> -----------------------------------------------
>          Key: AMQ-528
>          URL:
>      Project: ActiveMQ
>         Type: Bug

>     Versions: 4.0 M4
>  Environment: RedHat Linux Enterprise Server 3, Tomcat 5.5.15, MySQL 5.0.18 for Linux
>     Reporter: Leon Hu
>     Priority: Critical
>      Fix For: 4.0 RC2

> Setup: 
> 3 networked brokers, B1, B2, and B3, on 3 servers, connected using multicast discovery.
>  <broker useJmx="false" brokerName="B1"> 
>  <persistenceAdapter> 
>         <journaledJDBC journalLogFiles="5" dataDirectory="foo" dataSource="#mysql-ds"/>

>  </persistenceAdapter> 
>  <transportConnectors> 
>  <transportConnector uri="tcp://localhost:61616" discoveryUri="multicast://default"/>

>  </transportConnectors> 
>  <networkConnectors> 
>  <networkConnector uri="multicast://default"/> 
>  </networkConnectors> 
>  </broker> 
>  <bean id="mysql-ds" class="org.apache.commons.dbcp.BasicDataSource" destroy-method="close">

>            <property name="driverClassName" value="com.mysql.jdbc.Driver"/> 
>            <property name="url" value="jdbc:mysql://localhost/activemq?relaxAutoCommit=true"/>

>                  <property name="username" value="activemqUser"/> 
>                  <property name="password" value="activemqPwd"/> 
>                  <property name="poolPreparedStatements" value="true"/> 
>  </bean> 
> Similar for B2 and B3. 
> Two queues: Q1 and Q2. 
> Two producers, one for each queue, both producers connected to B1. 
> One Q1 cosumer connected to B1, another Q1 consumer on B2. 
> One Q2 consumer connected to B2, another Q2 consumer connected to B3. 
> Steps: 
> Start the brokers and start sending messages to the queue. 
> After a while, stop the brokers (Sequence does not matter) 
> See the errors in catalina.out of the Tomcat that has a broker with both producers and
consumers connected 
> The problems:
> 1. 
> Exception in thread "ActiveMQ Scheduler" java.lang.NullPointerException
>          at$SunPerfProvider.nanoTime(
>          at
>          at
>          at$ScheduledFutureTask.getDelay(
>  Exception in thread "ActiveMQ Scheduler" Exception in thread "ActiveMQ Scheduler" Exception
in thread "ActiveMQ Scheduler"      at
>          at
>          at$
>          at
>  java.lang.NullPointerException
>          at$SunPerfProvider.nanoTime(
>  Exception in thread "ActiveMQ Scheduler" Exception in thread "ActiveMQ Scheduler" Exception
in thread "ActiveMQ Scheduler"      at
>          at
>          at$ScheduledFutureTask.getDelay(
>          at
>          at
>  Exception in thread "ActiveMQ Scheduler" Exception in thread "ActiveMQ Scheduler"  
>          at
> 2. The same exception is logged to the log file (in my case catalina.out) for hundreds
of times, resulting a log file exceeding 150 MB in 2 minutes. 

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:

View raw message