activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rob Davies (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AMQ-734) Network connections do not reconnect when using static: with failover=true
Date Fri, 09 Jun 2006 08:32:51 GMT
    [ https://issues.apache.org/activemq/browse/AMQ-734?page=comments#action_36274 ] 

Rob Davies commented on AMQ-734:
--------------------------------

the reason for the fixed client_id is durable topic consumers. The network bridge amalgamates
multiple durable subscribers on the same topic in to one durable subscriber - to avoid duplicates
and improve performance. 

There is a keep alive protocol used with the tcp connector that should detect the network
outage - needs some more investigation to see why this doesn't appear to be working

> Network connections do not reconnect when using static: with failover=true
> --------------------------------------------------------------------------
>
>          Key: AMQ-734
>          URL: https://issues.apache.org/activemq/browse/AMQ-734
>      Project: ActiveMQ
>         Type: Bug

>   Components: Connector
>     Versions: 4.0
>  Environment: winxp java1.5.6
>     Reporter: tao
>     Priority: Critical
>      Fix For: 4.0.1

>
>
> If I pull out RJ45 port from net card ,waiting a time ,then put  RJ45 port net card .Network
is resume.Other computer always throw errors and net channel can't work.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   https://issues.apache.org/activemq/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message