activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hiram Chirino" <hi...@hiramchirino.com>
Subject Re: Build problem
Date Thu, 20 Apr 2006 17:08:45 GMT
We officially don't support using maven 2 to build yet (we are still
working on it).  Please use maven 1.

On 4/20/06, Li, Fan <fanli@amazon.com> wrote:
> Hi:
>
> When I tried to complie the latest source code from incubator-activemq-4.0-SNAPSHOT,
I get the following error
>
> Missing:
> ----------
> 1) org.apache.geronimo.specs:geronimo-servlet_2.4_spec:jar:1.0-SNAPSHOT
>
>   Try downloading the file manually from the project website.
>
>   Then, install it using the command:
>       mvn install:install-file -DgroupId=org.apache.geronimo.specs -DartifactId=geronimo-servlet_2.4_spec
\
>           -Dversion=1.0-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file
>
>   Path to dependency:
>         1) incubator-activemq:activemq-core:jar:4.0-SNAPSHOT
>         2) org.apache.geronimo.specs:geronimo-j2ee-jacc_1.0_spec:jar:1.0
>         3) org.apache.geronimo.specs:geronimo-servlet_2.4_spec:jar:1.0-SNAPSHOT
>
> 2) org.apache.geronimo.specs:geronimo-ejb_2.1_spec:jar:1.0-SNAPSHOT
>
>   Try downloading the file manually from the project website.
>
>   Then, install it using the command:
>       mvn install:install-file -DgroupId=org.apache.geronimo.specs -DartifactId=geronimo-ejb_2.1_spec
\
>           -Dversion=1.0-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file
>
>   Path to dependency:
>         1) incubator-activemq:activemq-core:jar:4.0-SNAPSHOT
>         2) org.apache.geronimo.specs:geronimo-j2ee-management_1.0_spec:jar:1.0
>         3) org.apache.geronimo.specs:geronimo-ejb_2.1_spec:jar:1.0-SNAPSHOT
>
> ----------
> 2 required artifacts are missing.
>
> for artifact:
>   incubator-activemq:activemq-core:jar:4.0-SNAPSHOT
>
> from the specified remote repositories:
>   central (http://repo1.maven.org/maven2),
>   apache.snapshots (http://cvs.apache.org/maven-snapshot-repository),
>   codehaus-snapshot (http://snapshots.maven.codehaus.org/maven2),
>   apache-maven1-snapshot (http://cvs.apache.org/repository),
>   maven-csharp (http://maven-csharp.javaforge.com/repo)
>
> I downloaded geronimo-spec-ejb-2.1-SNAPSHOT.jar and geronimo-spec-servlet-2.4-SNAPSHOT.jar
from http://cvs.apache.org/repository/geronimo-spec/jars/ . I tried to install it with command:
> mvn install:install-file -DgroupId=org.apache.geronimo.specs -DartifactId=gerpnimo-ejb_2.1_spec
-Dversion=2.1-SNAPSHOT -Dpackaging=jar -Dfile=/home/fanli/geronimo-spec-ejb-2.1-SNAPSHOT.jar
> And I get the following error:
>
> [INFO] Scanning for projects...
> [INFO] ------------------------------------------------------------------------
> [ERROR] FATAL ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] Error building POM (may not be this project's POM).
>
>
> Project ID: incubator-activemq:activemq-core
> POM Location: /home/fanli/incubator-activemq-4.0-SNAPSHOT/activemq-core/pom.xml
> Validation Messages:
>
>     [0]  'dependencies.dependency.version' is missing for incubator-activemq:activemq-jaas
>
>
> Reason: Failed to validate POM
>
>
> [INFO] ------------------------------------------------------------------------
> [INFO] Trace
> org.apache.maven.reactor.MavenExecutionException: Failed to validate POM
>         at org.apache.maven.DefaultMaven.getProjects(DefaultMaven.java:365)
>         at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:278)
>         at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:115)
>         at org.apache.maven.cli.MavenCli.main(MavenCli.java:256)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>         at java.lang.reflect.Method.invoke(Method.java:585)
>         at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
>         at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
>         at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
>         at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
> Caused by: org.apache.maven.project.InvalidProjectModelException: Failed to validate
POM
>         at org.apache.maven.project.DefaultMavenProjectBuilder.processProjectLogic(DefaultMavenProjectBuilder.java:902)
>         at org.apache.maven.project.DefaultMavenProjectBuilder.buildInternal(DefaultMavenProjectBuilder.java:738)
>         at org.apache.maven.project.DefaultMavenProjectBuilder.buildFromSourceFileInternal(DefaultMavenProjectBuilder.java:414)
>         at org.apache.maven.project.DefaultMavenProjectBuilder.build(DefaultMavenProjectBuilder.java:190)
>         at org.apache.maven.DefaultMaven.getProject(DefaultMaven.java:515)
>         at org.apache.maven.DefaultMaven.collectProjects(DefaultMaven.java:447)
>         at org.apache.maven.DefaultMaven.collectProjects(DefaultMaven.java:491)
>         at org.apache.maven.DefaultMaven.getProjects(DefaultMaven.java:351)
>         ... 11 more
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: < 1 second
> [INFO] Finished at: Thu Apr 20 09:54:58 PDT 2006
> [INFO] Final Memory: 1M/3M
> [INFO] ------------------------------------------------------------------------
>
> I am not that familiar with maven, am I doing something wrong?
>
> Thanks
> Fan Li
>
>
>


--
Regards,
Hiram

Mime
View raw message