activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: Which version of AMQ for geronimo 1.1?
Date Sun, 26 Mar 2006 17:33:34 GMT
How about we try get the latest 4.x trunk working in Geronimo 1.1?
There's heaps of bug fixes as well as some groovy new features in
there; we should make the swich at some point, so now seems as good a
time as any.

I think the only issue might be that the rest/ajax support (whichi is
optional) depends on Jetty 6.x; but the default configuration would
just be for tcp/ip using openwire/stomp.

James

On 3/26/06, David Jencks <david_jencks@yahoo.com> wrote:
> Geronimo 1.1 needs some changes in the activemq gbeans in order for
> activemq to be able to start and be managed by the console.  Which
> version(s) should I make the modifications in?  Should I make an AMQ
> branch for this?
>
> The problems I've identified so far are:
>
> - The management helper gbean needs extensive modifications to use
> AbstractNames rather than ObjectNames.
>
> - The JDBCPersistenceAdapterGBean uses an AMQ interface in its
> reference to dataSource: this no longer works as we now check that a
> target gbean declares the interface you ask for in a reference.
>
> Thanks
> david jencks
>
>


--

James
-------
http://radio.weblogs.com/0112098/

Mime
View raw message