activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hiram Chirino (JIRA)" <j...@activemq.org>
Subject [jira] Commented: (AMQ-492) Design error in MulticastDiscoveryAgent use of FailoverTransportConnector?
Date Fri, 17 Mar 2006 17:59:26 GMT
    [ http://jira.activemq.org/jira//browse/AMQ-492?page=comments#action_35805 ] 

Hiram Chirino commented on AMQ-492:
-----------------------------------

There was a question of why use failover??  If you don't expect a node in the cluster to be
taken offline for an extended period of time, using reliable helps the stablebility between
the brokers since by using failover, if a node in the cluster a transient outage, the rest
of the cluster will see him as still being online.

I think the gist of the last comment is that that broker was not reconnecting when a clustered
broker is bounced.

If so, then this is related to AMQ-639 which is now fixed.  

> Design error in MulticastDiscoveryAgent use of FailoverTransportConnector?
> --------------------------------------------------------------------------
>
>          Key: AMQ-492
>          URL: http://jira.activemq.org/jira//browse/AMQ-492
>      Project: ActiveMQ
>         Type: Bug

>   Components: Connector
>     Versions: 4.0
>  Environment: w2k and linux w java 1.5
>     Reporter: Dennis Cook
>     Assignee: Hiram Chirino
>      Fix For: 4.0

>
>
> I have been trying to get my head around the multicast discovery mechanism.  In particular
its use of the “FailoverTransport” class is bothering me.  The issue presented itself when
viewing the DEBUG level log entries that were generated after one broker of a pair, connected
using this discovery mechanism, was stopped.  The FailoverTransport went into a very tight
endless loop of attempts to reconnect.
> My first thought to “tweak” the Failover properties in the network connector URI. 
But alais, the uri was for the multicast not the failover.  No problem, just duplicate the
failover properties on the multicast agent.  After doing so, I started to think “why is failover
needed at all”  won’t the connection be reestablished when the broker returns and advertises
itself again?
> Can someone comment on this issue?  Is the bug that the failover properties where not
available or is the problem that failover was used at all?

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.activemq.org/jira//secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message