activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "james strachan (JIRA)" <j...@activemq.org>
Subject [jira] Commented: (AMQ-639) Broker is not re-connecting to a network of brokers after going down and then being brought back up
Date Fri, 17 Mar 2006 19:37:26 GMT
    [ http://jira.activemq.org/jira//browse/AMQ-639?page=comments#action_35814 ] 

james strachan commented on AMQ-639:
------------------------------------

BTW I wonder if the exception you are getting is related to this fix...

http://jira.activemq.org/jira/browse/AMQ-600

which was causing InvalidClientIDException to be thrown when network errors occur by handling
the IOException in the wrong way

> Broker is not re-connecting to a network of brokers after going down and then being brought
back up
> ---------------------------------------------------------------------------------------------------
>
>          Key: AMQ-639
>          URL: http://jira.activemq.org/jira//browse/AMQ-639
>      Project: ActiveMQ
>         Type: Bug

>   Components: Broker
>     Versions: 4.0 M4
>     Reporter: Brian Diesenhaus
>     Priority: Critical
>      Fix For: 4.0 M5

>
>
> I have set up a network of brokers with the following configuration:
> <beans xmlns="http://activemq.org/config/1.0">
>   <bean class="org.springframework.beans.factory.config.PropertyPlaceholderConfigurer"/>
>   
>   <broker brokerName="bfe-${HOSTNAME}" useJmx="true" persistent="false" managementContext="#mc">

>     <destinationPolicy>
>       <policyMap>
>         <policyEntries>
>           <policyEntry queue=">" memoryLimit="5000000"/>
>         </policyEntries>
>       </policyMap>
>    </destinationPolicy>
>    <memoryManager>
>      <usageManager limit="100000000"/>
>     </memoryManager> 
>  
>     <transportConnectors>
>     	<transportConnector uri="tcp://localhost:61616" discoveryUri="multicast://bfe2"/>

>     </transportConnectors>
>     
>     <networkConnectors>
>       <!-- by default just auto discover the other brokers -->
>       <networkConnector uri="multicast://bfe2"/>
>     </networkConnectors>
>    </broker>
>   
>  <bean id="mc" class="org.apache.activemq.broker.jmx.ManagementContext">
>     <property name="connectorPort" value="1099"/>
>     <property name="connectorPath" value="/jmxrmibfe-1"/>
>   </bean>
>  
> </beans>
> I then run a series of tests (producing and consuming on the network of brokers). Then
I shut one broker down and then start it up again  it can't see the other brokers in the network
but the other brokers can see it. 

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.activemq.org/jira//secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message