activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Johan Hallgren (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AMQ-660) Add support for MaxDB
Date Thu, 30 Mar 2006 16:29:08 GMT
    [ https://issues.apache.org/activemq/browse/AMQ-660?page=comments#action_35945 ] 

Johan Hallgren commented on AMQ-660:
------------------------------------

MaxDB does support subselects. When I run the SQL statement manually, I do get the same error
as in the log output. That error code maps to "System error" per the MxDB documentation, so
there's not much more info to be gained there.

FYI, when I create two smaller tables like below, the statement exexutes successfully:

create table activemq_msgs
(
expiration integer,
id integer,
container varchar(10) ascii
)
//
create table activemq_acks
(
last_acked_id integer,
container varchar(10) ascii
)

Hiram, if you could point me to the structure of the actual activemq_msgs and activemq_acks
tables, I can ask on the MaxDB mailing list and maybe get some hints on the issue. Judging
by the highlighting in MaxDB's SQL client, I thought that "container" may be a reserved word,
but if that were the issue, there'd be another error thrown, and my above experiment wouldn't
have worked either.

> Add support for MaxDB
> ---------------------
>
>          Key: AMQ-660
>          URL: https://issues.apache.org/activemq/browse/AMQ-660
>      Project: ActiveMQ
>         Type: New Feature

>   Components: Message Store
>     Reporter: Hiram Chirino
>     Assignee: Hiram Chirino
>      Fix For: 4.0 RC 2
>  Attachments: activemq.log
>
>
> Originaly reported on the user mailing list:
> http://www.nabble.com/Adding-support-for-MaxDB-in-ActiveMQ-JDBC-persistence-layer-t1334466.html#a3572564

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   https://issues.apache.org/activemq/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message