activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "james strachan (JIRA)" <j...@activemq.org>
Subject [jira] Commented: (AMQ-531) XBean has a runtime issue with Spring 2.0M2
Date Tue, 21 Mar 2006 16:08:26 GMT
    [ http://jira.activemq.org/jira//browse/AMQ-531?page=comments#action_35859 ] 

james strachan commented on AMQ-531:
------------------------------------

If Spring are not going to maintain binary compatibility with XBean then maybe we should just
ship a jar-jar'd version of Spring 1.2.x which is switched into the org.apache.xbean.spring
namespace so that folks can still use spring 2.x or later in their own config files, then
XBean will use an older version of spring


> XBean has a runtime issue with Spring 2.0M2
> -------------------------------------------
>
>          Key: AMQ-531
>          URL: http://jira.activemq.org/jira//browse/AMQ-531
>      Project: ActiveMQ
>         Type: Bug

>   Components: Broker
>     Versions: 4.0 M4
>  Environment: Spring 2.0M2
>     Reporter: Ben Hale
>     Assignee: james strachan
>      Fix For: 4.0 RC1

>
>
> Apparently there is an issue with XBean now that Spring 2.0 (starting with M2) is compiled
against a Java 5 compiler (http://jira.codehaus.org/browse/XB-7).  It's probably worth investigating
how long before XBean releases a fix and postponing the 4.0 release until they do.  If not,
at least documenting in a known issues list that ActiveMQ 4.0 can't working with 2.0M2 and
later until a later release where they do fix it.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.activemq.org/jira//secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message