activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adrian Co (JIRA)" <j...@activemq.org>
Subject [jira] Resolved: (AMQ-640) TEST TwoBrokerTopicSendReceiveUsingHttpTest Fails
Date Sat, 18 Mar 2006 00:15:25 GMT
     [ http://jira.activemq.org/jira//browse/AMQ-640?page=all ]
     
Adrian Co resolved AMQ-640:
---------------------------

      Assign To: Adrian Co  (was: Hiram Chirino)
     Resolution: Fixed
    Fix Version: 4.0 M5

This is a duplicate issue of AMQ-563.

> TEST TwoBrokerTopicSendReceiveUsingHttpTest Fails
> -------------------------------------------------
>
>          Key: AMQ-640
>          URL: http://jira.activemq.org/jira//browse/AMQ-640
>      Project: ActiveMQ
>         Type: Bug

>   Components: Test Cases
>     Versions: 4.0 M4
>  Environment: winxp
>     Reporter: Adrian Co
>     Assignee: Adrian Co
>      Fix For: 4.0 M5

>
>
> Broker networking using http fails. I think the problem is the bridge is sending the
BrokerInfo first before the ConnectionInfo (DemandForwardingBridgeSupport:185) without the
clientID from the ConnectionInfo, send fails. Failover transport tries to resend, but continue
failing. Tried sending the ConnectionInfo first, before the BrokerInfo, and it seems to work
ok, aside from a few lost messages. But I'm not sure if this is the way to go.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.activemq.org/jira//secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message