activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Strachan <james.strac...@gmail.com>
Subject Re: Build Problem
Date Thu, 16 Feb 2006 19:16:36 GMT
That indicates there were some JUnit test failures. We have some tests that
fail on some platforms with timing issues; its amazingly hard to write
highly asynchronous & concurrent message based unit test cases that always
work on every platform.

If you seach for [ERROR] you'll find the actual tests that failed. Then if
you look in "target/test-reports/TEST-$name.txt" (in the module thats being
built) you'll find the output of the test case. If you could post those it'd
really help us fix it.

James


On 2/16/06, Li, Fan <fanli@amazon.com> wrote:
>
> I have been trying to build the latest source code with maven 1.0.2 and
> kept getting build failure. This is the build for the latest SNAPSHOT. I am
> not sure if anyone had similar problem.
>
> BUILD FAILED
> File...... /home/fanli/.maven/cache/maven-multiproject-plugin-1.3.1
> /plugin.jelly
> Element... maven:reactor
> Line...... 217
> Column.... 9
> Unable to obtain goal [test:test] --
> /home/fanli/.maven/cache/maven-test-plugin-
> 1.6.2/plugin.jelly:181:54: <fail> There were test failures.
> Total time: 58 minutes 22 seconds
> Finished at: Thu Feb 16 09:49:19 PST 2006
>
> Thanks
> Fan
>
>
>


--

James
-------
http://radio.weblogs.com/0112098/

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message