activemq-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Francesco Di Tolla (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (APLO-332) Apollo not starting with cygwin under windows7
Date Tue, 30 Jul 2013 08:47:49 GMT

     [ https://issues.apache.org/jira/browse/APLO-332?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Francesco Di Tolla updated APLO-332:
------------------------------------

    Summary: Apollo not starting with cygwin under windows7  (was: Apollo no starting with
cygwin under windows7)
    
> Apollo not starting with cygwin under windows7
> ----------------------------------------------
>
>                 Key: APLO-332
>                 URL: https://issues.apache.org/jira/browse/APLO-332
>             Project: ActiveMQ Apollo
>          Issue Type: Bug
>          Components: apollo-cli
>    Affects Versions: 1.6
>         Environment: windows 7 32bit + cygwin + Java 1.7
>            Reporter: Francesco Di Tolla
>            Priority: Blocker
>
> the commands: "apollo" or "apollo create broker" fail with the error
> Exception in thread "main" java.lang.ClassNotFoundException: org.apache.activemq.apollo.cli.Apollo
> the problem seems to be related to the fact the $BOOTDIRS argument is passed as unix
path.
> To fix this I modified by hand, in my istallation, the bin/apollo script adding
> BOOTDIRS=`cygpath --path --windows "$BOOTDIRS"`
> in the if block for cygwin and it seems to work correctly.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message