activemq-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hiram Chirino (JIRA)" <>
Subject [jira] [Commented] (APLO-319) The retained message doesn't work
Date Thu, 25 Apr 2013 13:52:16 GMT


Hiram Chirino commented on APLO-319:

I suspect the topic is being auto deleted once there are no producers or consumers attached
to the topic.  To disable auto delete, add the following XML element within the virual_host
config element in apollo.xml: 

    <topic auto_delete_after="0"/>

We should change this so that the auto delete does not kick in when a retained message is
held in the topic.
> The retained message doesn't work
> ---------------------------------
>                 Key: APLO-319
>                 URL:
>             Project: ActiveMQ Apollo
>          Issue Type: Bug
>          Components: apollo-mqtt
>            Reporter: Frank Wen
> I use apollo as my mqtt server, but it seems the retain flag doesn't work.
> I publish a message to a topic, the message is set retained true. Then I start the consumer,
subscribe the topic, but no message received.
> I use fusesource mqtt-client and eclipse paho as client jar package, the same problem
> Another guy on stackoverflow have the same issue:
> Is it a bug? or I miss some configuration?

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

View raw message