activemq-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dej...@apache.org
Subject svn commit: r1439086 - in /activemq/trunk: activemq-karaf/src/main/resources/features.xml activemq-leveldb-store/pom.xml activemq-osgi/pom.xml
Date Sun, 27 Jan 2013 14:03:41 GMT
Author: dejanb
Date: Sun Jan 27 14:03:41 2013
New Revision: 1439086

URL: http://svn.apache.org/viewvc?rev=1439086&view=rev
Log:
https://issues.apache.org/jira/browse/AMQ-4034 - initial work on leveldb integration

Modified:
    activemq/trunk/activemq-karaf/src/main/resources/features.xml
    activemq/trunk/activemq-leveldb-store/pom.xml
    activemq/trunk/activemq-osgi/pom.xml

Modified: activemq/trunk/activemq-karaf/src/main/resources/features.xml
URL: http://svn.apache.org/viewvc/activemq/trunk/activemq-karaf/src/main/resources/features.xml?rev=1439086&r1=1439085&r2=1439086&view=diff
==============================================================================
--- activemq/trunk/activemq-karaf/src/main/resources/features.xml (original)
+++ activemq/trunk/activemq-karaf/src/main/resources/features.xml Sun Jan 27 14:03:41 2013
@@ -27,24 +27,6 @@
         <bundle dependency="true">mvn:org.apache.geronimo.specs/geronimo-jms_1.1_spec/1.1.1</bundle>
         <bundle dependency="true">mvn:org.apache.geronimo.specs/geronimo-j2ee-management_1.1_spec/1.0.1</bundle>
         <bundle dependency="true">mvn:commons-pool/commons-pool/${commons-pool-version}</bundle>
-        <!--<bundle dependency="true">mvn:commons-collections/commons-collections/${commons-collections-version}</bundle>-->
-        <!--<bundle dependency='true'>mvn:commons-lang/commons-lang/${commons-lang-version}</bundle>-->
-        <!--<bundle dependency="true">mvn:commons-codec/commons-codec/1.4</bundle>-->
-        <!--<bundle dependency="true">mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.velocity/1.7_5</bundle>-->
-        <!--<bundle dependency="true">mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jasypt/1.9.0_1</bundle>-->
-        <!--<bundle dependency="true">mvn:org.apache.servicemix.specs/org.apache.servicemix.specs.stax-api-1.0/${servicemix.specs.version}</bundle>-->
-        <!--<bundle dependency="true">mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.xpp3/${xpp3-bundle-version}</bundle>-->
-        <!--<bundle dependency="true">mvn:joda-time/joda-time/${jodatime-bundle-version}</bundle>-->
-        <!--<bundle dependency="true">mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jdom/${jdom-bundle-version}</bundle>-->
-        <!--<bundle dependency="true">mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.dom4j/${dom4j-bundle-version}</bundle>-->
-        <!--<bundle dependency="true">mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.xstream/${xstream-bundle-version}</bundle>-->
-        <!--<bundle dependency="true">mvn:org.apache.aries.transaction/org.apache.aries.transaction.manager/${aries-version}</bundle>-->
-        <!--<bundle>mvn:org.apache.activemq/kahadb/${project.version}</bundle>-->
-        <!--<bundle>mvn:org.apache.activemq/activemq-console/${project.version}</bundle>-->
-        <!--<bundle>mvn:org.apache.activemq/activemq-ra/${project.version}</bundle>-->
-        <!--<bundle>mvn:org.apache.activemq/activemq-pool/${project.version}</bundle>-->
-        <!--<bundle>mvn:org.apache.activemq/activemq-karaf/${project.version}</bundle>-->
-        <!--<bundle>mvn:org.apache.aries.transaction/org.apache.aries.transaction.manager/${aries-version}</bundle>-->
     </feature>
 
     <feature name="activemq-broker" version="${project.version}" resolver="(obr)" start-level="50">
@@ -118,10 +100,11 @@
     </feature>
 
     <feature name="activemq-extra" version="${project.version}" resolver="(obr)" start-level="50">
+        <bundle dependency="true">mvn:org.scala-lang/scala-library/${scala-version}</bundle>
         <bundle>mvn:org.fusesource.mqtt-client/mqtt-client/${mqtt-client-version}</bundle>
         <bundle>mvn:org.fusesource.hawtbuf/hawtbuf/${hawtbuf-version}</bundle>
-        <bundle>mvn:org.apache.activemq/activemq-leveldb/${project.version}/jar/bundle</bundle>
         <bundle>mvn:org.fusesource.hawtdispatch/hawtdispatch/${hawtdispatch-version}</bundle>
+        <bundle>mvn:org.fusesource.hawtdispatch/hawtdispatch-scala/${hawtdispatch-version}</bundle>
         <bundle>mvn:org.fusesource.hawtdispatch/hawtdispatch-transport/${hawtdispatch-version}</bundle>
     </feature>
 </features>

Modified: activemq/trunk/activemq-leveldb-store/pom.xml
URL: http://svn.apache.org/viewvc/activemq/trunk/activemq-leveldb-store/pom.xml?rev=1439086&r1=1439085&r2=1439086&view=diff
==============================================================================
--- activemq/trunk/activemq-leveldb-store/pom.xml (original)
+++ activemq/trunk/activemq-leveldb-store/pom.xml Sun Jan 27 14:03:41 2013
@@ -365,6 +365,53 @@
           </execution>
         </executions>
       </plugin>
+      <plugin>
+        <groupId>org.fusesource.mvnplugins</groupId>
+        <artifactId>maven-uberize-plugin</artifactId>
+        <version>1.14</version>
+        <executions>
+          <execution>
+            <id>all</id>
+            <phase>package</phase>
+            <goals><goal>uberize</goal></goals>
+          </execution>
+        </executions>
+        <configuration>
+          <uberArtifactAttached>true</uberArtifactAttached>
+          <uberClassifierName>uber</uberClassifierName>
+          <artifactSet>
+            <includes>
+              <!-- <include>org.scala-lang:scala-library</include> -->
+              <include>org.fusesource.hawtdispatch:hawtdispatch</include>
+              <include>org.fusesource.hawtdispatch:hawtdispatch-scala</include>
+              <include>org.fusesource.hawtbuf:hawtbuf</include>
+              <include>org.fusesource.hawtbuf:hawtbuf-proto</include>
+
+              <include>org.iq80.leveldb:leveldb-api</include>
+
+              <include>org.iq80.leveldb:leveldb</include>
+              <!--
+              <include>org.xerial.snappy:snappy-java</include>
+              <include>com.google.guava:guava</include>
+              -->
+              <include>org.xerial.snappy:snappy-java</include>
+
+              <include>org.fusesource.leveldbjni:leveldbjni</include>
+              <include>org.fusesource.leveldbjni:leveldbjni-osx</include>
+              <include>org.fusesource.leveldbjni:leveldbjni-linux32</include>
+              <include>org.fusesource.leveldbjni:leveldbjni-linux64</include>
+              <include>org.fusesource.hawtjni:hawtjni-runtime</include>
+
+              <!-- include bits need to access hdfs as a client -->
+              <include>org.apache.hadoop:hadoop-core</include>
+              <include>commons-configuration:commons-configuration</include>
+              <include>org.codehaus.jackson:jackson-mapper-asl</include>
+              <include>org.codehaus.jackson:jackson-core-asl</include>
+
+            </includes>
+          </artifactSet>
+        </configuration>
+      </plugin>
     </plugins>
     <pluginManagement>
       <plugins>

Modified: activemq/trunk/activemq-osgi/pom.xml
URL: http://svn.apache.org/viewvc/activemq/trunk/activemq-osgi/pom.xml?rev=1439086&r1=1439085&r2=1439086&view=diff
==============================================================================
--- activemq/trunk/activemq-osgi/pom.xml (original)
+++ activemq/trunk/activemq-osgi/pom.xml Sun Jan 27 14:03:41 2013
@@ -35,7 +35,9 @@
 
     </activemq.osgi.import.pkg>
     <activemq.osgi.export>
-      org.apache.activemq*;version=${project.version};-noimport:=true;-split-package:=merge-first
+      org.apache.activemq*;version=${project.version};-noimport:=true;-split-package:=merge-first,
+      org.iq80*;-noimport:=true;-split-package:=merge-first,
+      org.fusesource*;-noimport:=true;-split-package:=merge-first
     </activemq.osgi.export>
     <activemq.osgi.dynamic.import>*</activemq.osgi.dynamic.import>
     <surefire.argLine>-Xmx512M</surefire.argLine>
@@ -60,6 +62,8 @@
     <dependency>
       <groupId>${project.groupId}</groupId>
       <artifactId>activemq-leveldb-store</artifactId>
+      <version>${project.version}</version>
+      <classifier>uber</classifier>
     </dependency>
     <dependency>
       <groupId>${project.groupId}</groupId>



Mime
View raw message