activemq-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Markus Lang (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (APLO-269) NoSuchMethodError in HawtDispatch after updating from Apollo 1.4 to 1.5
Date Sun, 18 Nov 2012 01:38:12 GMT

     [ https://issues.apache.org/jira/browse/APLO-269?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Markus Lang closed APLO-269.
----------------------------

    Resolution: Not A Problem

I've found my problem while having a closer look at my Maven dependencies. I had a dependency
to org.fusesource.stompjms:stompjms-client in version 1.12 in another project. Updating to
version 1.13 fixed the problem with having the wrong version of the HawtDispatch library in
the runtime scope.

Sorry for raising false alarms and thanks again for your help!
                
> NoSuchMethodError in HawtDispatch after updating from Apollo 1.4 to 1.5
> -----------------------------------------------------------------------
>
>                 Key: APLO-269
>                 URL: https://issues.apache.org/jira/browse/APLO-269
>             Project: ActiveMQ Apollo
>          Issue Type: Bug
>    Affects Versions: 1.5
>         Environment: java version "1.7.0_09"
> Java(TM) SE Runtime Environment (build 1.7.0_09-b05)
> Java HotSpot(TM) 64-Bit Server VM (build 23.5-b02, mixed mode)
> Dependencies used from public Maven repositories:
> org.apache.activemq:apollo-broker:1.5
> org.apache.activemq:apollo-web:1.5
> org.apache.activemq:apollo-stomp:1.5
>            Reporter: Markus Lang
>
> After updating from ActiveMQ Apollo from version 1.4 to 1.5 I do receive NoSuchMethodErrors
triggered by the HawtDispatch library:
> Exception in thread "hawtdispatch-DEFAULT-1" java.lang.NoSuchMethodError: org.fusesource.hawtdispatch.transport.TransportServer.setBlockingExecutor(Ljava/util/concurrent/Executor;)V
> 	at org.apache.activemq.apollo.broker.AcceptingConnector._start(Connector.scala:246)
> 	at org.apache.activemq.apollo.util.BaseService$$anonfun$start_task$1$1.do_start$1(BaseService.scala:88)
> 	at org.apache.activemq.apollo.util.BaseService$$anonfun$start_task$1$1.apply$mcV$sp(BaseService.scala:104)
> 	at org.fusesource.hawtdispatch.package$$anon$3.run(hawtdispatch.scala:357)
> 	at org.fusesource.hawtdispatch.internal.SerialDispatchQueue.run(SerialDispatchQueue.java:96)
> 	at org.fusesource.hawtdispatch.internal.pool.SimpleThread.run(SimpleThread.java:77)
> While trying to send some messages I do run into the following NoSuchMethodErrors:
> Exception in thread "hawtdispatch-DEFAULT-1" java.lang.NoSuchMethodError: org.fusesource.hawtdispatch.transport.TcpTransportServer.setSendBufferSize(I)V
> 	at org.apache.activemq.apollo.broker.AcceptingConnector.update_buffer_settings(Connector.scala:298)
> 	at org.apache.activemq.apollo.broker.Broker$$anonfun$tune_send_receive_buffers$1.apply(Broker.scala:452)
> 	at org.apache.activemq.apollo.broker.Broker$$anonfun$tune_send_receive_buffers$1.apply(Broker.scala:451)
> 	at scala.collection.MapLike$DefaultValuesIterable$$anonfun$foreach$4.apply(MapLike.scala:203)
> 	at scala.collection.MapLike$DefaultValuesIterable$$anonfun$foreach$4.apply(MapLike.scala:203)
> 	at scala.collection.mutable.LinkedHashMap.foreach(LinkedHashMap.scala:129)
> 	at scala.collection.MapLike$DefaultValuesIterable.foreach(MapLike.scala:203)
> 	at org.apache.activemq.apollo.broker.Broker.tune_send_receive_buffers(Broker.scala:451)
> 	at org.apache.activemq.apollo.broker.Broker$$anonfun$_start$2.apply$mcV$sp(Broker.scala:374)
> 	at org.apache.activemq.apollo.util.BaseService$$anonfun$schedule$1$1.apply$mcV$sp(BaseService.scala:171)
> 	at org.fusesource.hawtdispatch.package$$anon$3.run(hawtdispatch.scala:357)
> 	at org.fusesource.hawtdispatch.internal.SerialDispatchQueue.run(SerialDispatchQueue.java:96)
> 	at org.fusesource.hawtdispatch.internal.pool.SimpleThread.run(SimpleThread.java:77)
> While building my project with Gradle I've noticed that at least one of the three referenced
Maven artefacts does resolve to HawtDispatch in version 1.11 whereas version 1.12 of the library
is used at runtime. If I downgrade my project again to ActiveMQ Apollo in version 1.4 everything
works as expected.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message