activemq-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian Posta (JIRA)" <j...@apache.org>
Subject [jira] [Created] (APLO-230) Default timeout for OpenWire inactivity is incorrect
Date Sun, 29 Jul 2012 05:25:33 GMT
Christian Posta created APLO-230:
------------------------------------

             Summary: Default timeout for OpenWire inactivity is incorrect
                 Key: APLO-230
                 URL: https://issues.apache.org/jira/browse/APLO-230
             Project: ActiveMQ Apollo
          Issue Type: Bug
          Components: apollo-openwire
    Affects Versions: 1.3
            Reporter: Christian Posta


I think (based on what ActiveMQ has as its defaults) that the max_inactivity_duration and
max_inactivity_duration_initial_delay default values might be incorrect. ActiveMQ has them
at 30s:
From: OpenWireFormatFactory:
    private long maxInactivityDuration = 30*1000;
    private long maxInactivityDurationInitalDelay = 10*1000;

But Apollo has them set for 8.33 hrs:
DEFAULT_WIREFORMAT_SETTINGS.setMaxInactivityDuration(30 * 1000 * 1000);
  DEFAULT_WIREFORMAT_SETTINGS.setMaxInactivityDurationInitalDelay(10 * 1000 * 1000);

Patch is easy, can submit it, but just wanted to confirm that this is indeed wrong?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message