ace-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pierre De Rop <pierre.de...@gmail.com>
Subject Ace-Obr not using the latest repoindex version
Date Sat, 11 Jun 2016 09:49:38 GMT
Hi all,

I'm using the latest ace from the trunk, and I have an issue with ace-obr,
which is currently using an version of repo index
(org.osgi.impl.bundle.repoindex.lib-0.0.4.jar).

I would like to know if it's possible to update the cnf/localrepo in order
to use the latest stable version of repoindex (which is currently
org.osgi.impl.bundle.repoindex.lib-3.2.0.jar if I'm correct) ?

Indeed, I have some resolve errors under bndtools when using ace-obr and
the old repoindex, which seems to generate invalid requirements in the obr
index when you have some bundles with some DS components (I have a mix of
DM/DS components in my applications).

thanks;

cheers
/Pierre

[1] https://github.com/bndtools/bndtools/issues/739
[2] https://github.com/bndtools/bnd/issues/396

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message