ace-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcel Offermans <marcel.offerm...@luminis.nl>
Subject Re: Ace artifacts on maven central ?
Date Thu, 10 Dec 2015 13:10:54 GMT
Hello Cristiano,
On 10 December 2015 at 14:01:01, Cristiano Gavião (cvgaviao@gmail.com) wrote:

I read somewhere that Apache Ace follows the OSGi Deployment Admin spec, 
so we decided to try it. 
That is correct.

We are using Equinox and p2 as its repository in our environment and 
building our bundles with tycho and maven-bundle-plugin. 
Ok.

So in order to have the deployment agent installed in our p2 we need to 
have the required artifacts at least in a maven repository. 
The agent consists of only a single bundle.

But in the maven central the latest apache ace artifacts is in version 
0.8.1 and was delivered in 2011 ! 
Yes. During that time we were still using Maven to build ACE, but we have since moved on to
using Bndtools and an Ant based build that is automatically generated by Bndtools. That means
we have also changed the way we do releases. Our source and binary convenience releases are
stored in the official Apache release repository. We are not doing any convenience releases
at the moment towards any other repositories.

Is Apache ace not being delivered to maven central anymore ? why? 
We have been considering this, generating the Maven metadata from our build and using that
to publish those artifacts but that process is not done yet. If you want to help us with it,
please do.

For now my advice would be to manually upload the single bundle with the agent to your own
Maven repository and use that in your builds.

Greetings, Marcel




Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message