ace-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daan Veldhof <daanveld...@gmail.com>
Subject Re: autoregister and -approve targets
Date Wed, 21 Oct 2015 12:04:07 GMT
Hi,

2015-10-21 13:05 GMT+02:00 Jan Willem Janssen <janwillem.janssen@luminis.eu>
:

> Hi,
>
> > On 20 Oct 2015, at 10:11, Daan Veldhof <daanveldhof@gmail.com> wrote:
> >
> > I want to autoregister and autoapprove my targets when they send their
> > first auditlog to the ace server. I don't know the exact name of the
> > targets so I can't preregister them. Is there any configuration that can
> > handle this?
>
> There is a way to automatically approve any target that registers to the
> server for the first time. All you need to do is deploy the bundle
> `org.apache.ace.client.automation` at your ACE server, and update the
> corresponding configuration file `org.apache.ace.client.automation.cfg`
> in your ACE server’s “conf/“ directory (the default configuration will
> simply approve all updates to any target it sees).
>
>
I've already tried this with the default configuration, but no target is
registered or approved.

Approach:
I added the org.apache.ace.client.automation bundle to the Run Bundles in
server-allinone.bndrun. When I add a target it's not registered or approved
when I look at the WebUI.
When I set a breakpoint at AutoTargetOperator:start() it's only reached
when I get a workspace through the REST API (POST /client/work) , GoGo
shell (' cw ') or if I log in at the Web UI.
Also when I try to get a workspace through the REST API or GoGo shell I get
an ' IllegalStateException: Another user is logged in '. I have to do it a
second time before I get a workspace.
When I set a breakpoint at AuditLogProcessTask:process() it's never reached

Is there anything I'm missing?

I'm using the https://svn.apache.org/repos/asf/ace/trunk

Regards
Daan Veldhof

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message