ace-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Driessen <thomas.driessen...@gmail.com>
Subject Setup ACE with Apache Jenkins
Date Mon, 23 Mar 2015 12:49:32 GMT
Hello,

I'm currently trying to setup Apache ACE together with Jenkins. For this
purpose i set up a windows machine running jenkins on port 8080. On the
same machine I started the ACE Server (server-allinone.jar) on port 9000
via the command:

java /
-Dorg.osgi.service.http.port=9000 /
-Dorg.apache.ace.server=localhost:9000 /
-Dorg.apache.ace.obr=localhost:9000 /
-jar server-allinone.jar

Now I tried to autodeploy the jars created by jenkins into the obr of ACE,
as described in this video at 31:00:

https://youtu.be/4S_zvgG_MLw?t=31m

I tried to start the client.jar via a shell command as shown in the video
but got the following problem:

When invoking the jar with the script "script.gogo" and the parameter
-Dgosh.args=--nointeractive, I get the error:
"org.apache.felix.gogo.runtime.CommandNotFoundException: Command not found:
exit"

After that I tried to invoke the jar withour --nointeractive, but then I
get ever changing errors like NullPointerExceptions/
ClassDefNotFoundExceptions/Framework is not running messages etc. those
seem not to be deterministic, as I always get a different error.

Can someone please give me a hint what I have to do in order to deploy the
artifacts generated by jenkins into the obr of apache ACE?

Best regards,
Thomas

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message