ace-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guy Davis <guydavis...@gmail.com>
Subject ACE 2.0.1 web UI not showing associations after drag?
Date Thu, 05 Jun 2014 21:07:45 GMT
Good day,

I've been following the Getting Started guide and have had trouble getting
the expected behavior from the web UI.  In particular, I can drag an
artifact to a feature, then that to the distribution, etc but I'm not
seeing the same node expansion showing mappings after the dragging:

[image: Inline image 1]

Following through the workflow I can push the HelloWorldBundle out to the
target and see it's start() get called.  However, I think perhaps my
browser is not supported by the web UI as I was expecting more visual
feedback of the mappings.  I'm using Chrome 35.0.1916.114 m and also MS IE
10.0.9200...

As context, I'm evaluating using Apache ACE as a means of modular component
deployment at customer sites where they are running  JBoss application
server(s).  I'd like to integrate the ACE server into our current admin
console app on the master JBoss server.  Each cluster node would have an
embedded instance of the ACE (client/target), polling for updates.  Each
customer site would be either internal VMs or cloud systems.  The bundles
would simply consist of files destined to be deployed into the appropriate
JBoss folders along with execution of custom upgrade logic (Java, Ant,
etc). Back on our corporate network, we'd have a OBR repository configured
with versions of all our deployable apps and components.  The ACE servers
out at customer sites would pull down from this central repository.

Something like this:
[image: Inline image 2]

The plugin model of pulling from a single Update Center is similar to
functionality built into apps like Sonar and Jenkins.  I'd appreciate any
feedback on this idea.  Is Apache ACE a reasonable fit here?

Thanks in advance,
Guy

Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message