ace-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bram Pouwelse <b...@pouwelse.com>
Subject Re: Deployment breaks after adding new artifacts
Date Mon, 26 Aug 2013 09:36:29 GMT
I've found what caused this issue, I'd removed "old" resources from the ace
obr repository but forgot to remove one of the corresponding artifacts (and
this artifact was still linked to a feature). Removing the artifact solved
the issue.

When creating the artifacts from the web client the "Add artifact" dialog
only shows resources that don't have an artifact defintion. But when
creating artifacts using the ace cli the list "Artifacts in repository" in
the "Add artifact" dialog displays all resources which makes it easier to
make mistakes like this.





2013/8/26 Bram Pouwelse <bram@pouwelse.com>

> Please ignore the previous message, accidentally hit send...
>
>
> Hi,
>
> I've built from source again and that seems to work just fine. But this
> morning the target server ran out of memory ... after killing the target
> and clearing the bundle cache the target keeps deploying the software over
> and over again.
>
> This is a part of the list bundles output after keeping the target running
> for a while.
>
> g! lb
> START LEVEL 1
>    ID|State      |Level|Name
>     0|Active     |    0|System Bundle (4.0.3)
> .....
> 5711|Installed  |    1|Joda-Time (2.2.0)
>
>
> (the application has 120 bundles in the deployment package)
>
>
> I've tried starting the target with different id and assigned the feature
> but this didn't "solve" the issue. The log on the server only has DEBUG
> messages, and all bundle install events are visible in the target details
> panel in the web client.
>
>
> Hope this one is as easy to fix as the last issue ;)
>
> Thanks,
>
> Bram
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message