ace-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bryan Hunt <bh...@mac.com>
Subject Re: Server fails to start
Date Tue, 16 Jul 2013 20:28:39 GMT
Nevermind ... I just found the problem.  It doesn't work with JDK 1.8.  Switching to JDK 1.7
fixed the problem.

Bryan

On Jul 16, 2013, at 3:24 PM, Bryan Hunt <bhunt@mac.com> wrote:

> I downloaded ACE 1.0 to give it a spin, and the server fails to start.  It seems to be
missing the osgi.wiring bundle ...
> 
> homer:server-allinone bhunt$ java -jar server-allinone.jar 
> ! could not resolve the bundles
> ! Failed to start bundle org.apache.ace.client.repository.helper.base-1.0.0, exception
Unresolved constraint in bundle org.apache.ace.client.repository.helper.base [20]: Unable
to resolve 20.0: missing requirement [20.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.ace.connectionfactory)(version>=1.0.0)(!(version>=2.0.0)))
[caused by: Unable to resolve 28.0: missing requirement [28.0] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)]
> ! Failed to start bundle org.apache.ace.client.repository.helper.configuration-1.0.0,
exception Unresolved constraint in bundle org.apache.ace.client.repository.helper.configuration
[22]: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)
> ! Failed to start bundle org.apache.ace.client.repository.impl-1.0.0, exception Unresolved
constraint in bundle org.apache.ace.client.repository.impl [23]: Unable to resolve 23.0: missing
requirement [23.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.ace.connectionfactory)(version>=1.0.0)(!(version>=2.0.0)))
[caused by: Unable to resolve 28.0: missing requirement [28.0] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)]
> ____________________________
> Welcome to Apache Felix Gogo
> 
> g! ! Failed to start bundle org.apache.ace.configurator.useradmin.task-1.0.0, exception
Unresolved constraint in bundle org.apache.ace.configurator.useradmin.task [26]: Unable to
resolve 26.0: missing requirement [26.0] osgi.wiring.package; (osgi.wiring.package=org.apache.ace.connectionfactory)
[caused by: Unable to resolve 28.0: missing requirement [28.0] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)]
> ! Failed to start bundle org.apache.ace.connectionfactory-1.0.0, exception Unresolved
constraint in bundle org.apache.ace.connectionfactory [28]: Unable to resolve 28.0: missing
requirement [28.0] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)
> ! Failed to start bundle org.apache.ace.deployment.provider.repositorybased-1.0.0, exception
Unresolved constraint in bundle org.apache.ace.deployment.provider.repositorybased [31]: Unable
to resolve 31.0: missing requirement [31.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)
> ! Failed to start bundle org.apache.ace.deployment.servlet-1.0.0, exception Unresolved
constraint in bundle org.apache.ace.deployment.servlet [32]: Unable to resolve 32.0: missing
requirement [32.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.ace.deployment.streamgenerator)(version>=1.0.0)(!(version>=2.0.0)))
[caused by: Unable to resolve 33.0: missing requirement [33.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.ace.connectionfactory)(version>=1.0.0)(!(version>=2.0.0)))
[caused by: Unable to resolve 28.0: missing requirement [28.0] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)]]
> ! Failed to start bundle org.apache.ace.deployment.streamgenerator-1.0.0, exception Unresolved
constraint in bundle org.apache.ace.deployment.streamgenerator [33]: Unable to resolve 33.0:
missing requirement [33.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.ace.connectionfactory)(version>=1.0.0)(!(version>=2.0.0)))
[caused by: Unable to resolve 28.0: missing requirement [28.0] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)]
> ! Failed to start bundle org.apache.ace.log.server.ui-1.0.0, exception Unresolved constraint
in bundle org.apache.ace.log.server.ui [41]: Unable to resolve 41.0: missing requirement [41.0]
osgi.wiring.package; (&(osgi.wiring.package=org.apache.ace.webui)(version>=1.0.0)(!(version>=2.0.0)))
[caused by: Unable to resolve 59.0: missing requirement [59.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)]
> ! Failed to start bundle org.apache.ace.nodelauncher.amazon-1.0.0, exception Unresolved
constraint in bundle org.apache.ace.nodelauncher.amazon [42]: Unable to resolve 42.0: missing
requirement [42.0] osgi.wiring.package; (osgi.wiring.package=javax.activation)
> ! Failed to start bundle org.apache.ace.nodelauncher.ui-1.0.0, exception Unresolved constraint
in bundle org.apache.ace.nodelauncher.ui [44]: Unable to resolve 44.0: missing requirement
[44.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.ace.nodelauncher.amazon)(version>=1.0.0)(!(version>=2.0.0)))
[caused by: Unable to resolve 42.0: missing requirement [42.0] osgi.wiring.package; (osgi.wiring.package=javax.activation)]
> ! Failed to start bundle org.apache.ace.resourceprocessor.useradmin-1.0.0, exception
Unresolved constraint in bundle org.apache.ace.resourceprocessor.useradmin [52]: Unable to
resolve 52.0: missing requirement [52.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)
> ! Failed to start bundle org.apache.ace.tageditor-1.0.0, exception Unresolved constraint
in bundle org.apache.ace.tageditor [54]: Unable to resolve 54.0: missing requirement [54.0]
osgi.wiring.package; (&(osgi.wiring.package=org.apache.ace.webui)(version>=1.0.0)(!(version>=2.0.0)))
[caused by: Unable to resolve 59.0: missing requirement [59.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)]
> ! Failed to start bundle org.apache.ace.target.mgmt.ui-1.0.0, exception Unresolved constraint
in bundle org.apache.ace.target.mgmt.ui [55]: Unable to resolve 55.0: missing requirement
[55.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.ace.webui)(version>=1.0.0)(!(version>=2.0.0)))
[caused by: Unable to resolve 59.0: missing requirement [59.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)]
> ! Failed to start bundle org.apache.ace.useradmin.ui-1.0.0, exception Unresolved constraint
in bundle org.apache.ace.useradmin.ui [56]: Unable to resolve 56.0: missing requirement [56.0]
osgi.wiring.package; (&(osgi.wiring.package=org.apache.ace.webui)(version>=1.0.0)(!(version>=2.0.0)))
[caused by: Unable to resolve 59.0: missing requirement [59.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)]
> ! Failed to start bundle org.apache.ace.verifier.ui-1.0.0, exception Unresolved constraint
in bundle org.apache.ace.verifier.ui [58]: Unable to resolve 58.0: missing requirement [58.0]
osgi.wiring.package; (&(osgi.wiring.package=org.apache.ace.connectionfactory)(version>=1.0.0)(!(version>=2.0.0)))
[caused by: Unable to resolve 28.0: missing requirement [28.0] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)]
> ! Failed to start bundle org.apache.ace.webui.vaadin-1.0.0, exception Unresolved constraint
in bundle org.apache.ace.webui.vaadin [59]: Unable to resolve 59.0: missing requirement [59.0]
osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)
> Bundle Indexer | v2.2
> (c) 2007 OSGi, All Rights Reserved
> 
> g! lb
> START LEVEL 1
>   ID|State      |Level|Name
>    0|Active     |    0|System Bundle (4.0.3)
>    1|Active     |    1|Apache Felix Dependency Manager (3.1.0)
>    2|Active     |    1|Apache Felix User Admin Service (1.0.2)
>    3|Active     |    1|Apache Felix User Admin file-based repository store (1.0.1)
>    4|Active     |    1|Apache Felix Log Service (1.0.1)
>    5|Active     |    1|Apache Felix Preferences Service (1.0.4)
>    6|Active     |    1|Apache Felix Configuration Admin Service (1.6.0)
>    7|Active     |    1|Apache Felix EventAdmin (1.2.14)
>    8|Active     |    1|Apache Felix Gogo Runtime (0.10.0)
>    9|Active     |    1|Apache Felix Gogo Shell (0.10.0)
>   10|Active     |    1|Apache Felix Gogo Command (0.12.0)
>   11|Active     |    1|Apache Felix Http Jetty (2.2.0)
>   12|Active     |    1|Apache Felix Dependency Manager Shell (3.0.1)
>   13|Active     |    1|osgi.cmpn (4.3.1.201210102024)
>   14|Active     |    1|Vaadin (6.8.4)
>   15|Active     |    1|Apache ACE Authentication API (1.0.0)
>   16|Active     |    1|Apache ACE Authentication Service (1.0.0)
>   17|Active     |    1|Apache ACE Authentication Basic-Auth processor (1.0.0)
>   18|Active     |    1|Apache ACE Authentication Password processor (1.0.0)
>   19|Active     |    1|Apache ACE Client Repository API (1.0.0)
>   20|Installed  |    1|Apache ACE Client Repository Helper Base (1.0.0)
>   21|Active     |    1|Apache ACE Client Repository Bundle Helper (1.0.0)
>   22|Installed  |    1|Apache ACE Client Repository Configuration Helper (1.0.0)
>   23|Installed  |    1|Apache Ace Client Repository factory (1.0.0)
>   24|Active     |    1|Apache ACE Client REST (1.0.0)
>   25|Active     |    1|Apache ACE Configurator Serveruseradmin (1.0.0)
>   26|Installed  |    1|Apache ACE Configurator Useradmintask (1.0.0)
>   27|Active     |    1|Apache ACE Configurator (1.0.0)
>   28|Installed  |    1|Apache ACE ConnectionFactory (1.0.0)
>   29|Active     |    1|Apache ACE ConsoleLogger (1.0.0)
>   30|Active     |    1|Apache ACE Deployment Provider API (1.0.0)
>   31|Installed  |    1|Apache ACE Deployment Provider Repository (1.0.0)
>   32|Installed  |    1|Apache ACE Deployment Servlet (1.0.0)
>   33|Installed  |    1|Apache ACE Deployment StreamGenerator (1.0.0)
>   34|Active     |    1|Apache ACE Discovery API (1.0.0)
>   35|Active     |    1|Apache ACE HTTP Listener (1.0.0)
>   36|Active     |    1|Apache ACE HTTP Redirector (1.0.0)
>   37|Active     |    1|Apache ACE Log API (1.0.0)
>   38|Active     |    1|Apache ACE Log Server Servlet (1.0.0)
>   39|Active     |    1|Apache ACE Log Server Store API (1.0.0)
>   40|Active     |    1|Apache ACE Server Store file (1.0.0)
>   41|Installed  |    1|Apache ACE Log Server UI (1.0.0)
>   42|Installed  |    1|Apache ACE NodeLauncher Amazon (1.0.0)
>   43|Active     |    1|Apache ACE NodeLauncher API (1.0.0)
>   44|Installed  |    1|Apache ACE NodeLauncher UI (1.0.0)
>   45|Active     |    1|Apache ACE OBR MetaData (1.0.0)
>   46|Active     |    1|Apache ACE OBR Servlet (1.0.0)
>   47|Active     |    1|Apache ACE OBR Storage (1.0.0)
>   48|Active     |    1|Apache ACE Range API (1.0.0)
>   49|Active     |    1|Apache ACE Repository API (1.0.0)
>   50|Active     |    1|Apache ACE Repository Service (1.0.0)
>   51|Active     |    1|Apache ACE Repository Servlet (1.0.0)
>   52|Installed  |    1|Apache ACE ResourceProcessor UserAdmin (1.0.0)
>   53|Active     |    1|Apache ACE Scheduler Service (1.0.0)
>   54|Installed  |    1|Apache ACE TagEditorUI (1.0.0)
>   55|Installed  |    1|Apache ACE TargetMgmtUI (1.0.0)
>   56|Installed  |    1|Apache ACE UserAdminUI (1.0.0)
>   57|Active     |    1|Apache ACE Verifier Service (1.0.0)
>   58|Installed  |    1|Apache ACE Verfifier UI (1.0.0)
>   59|Installed  |    1|Apache ACE WebUI Vaadin (1.0.0)
> 


Mime
View raw message