ace-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bram de Kruijff <bdekrui...@gmail.com>
Subject Re: Can not build ace trunk with command line.
Date Tue, 29 Jul 2014 12:37:27 GMT
On Tue, Jul 29, 2014 at 11:00 AM, Paul Bakker <paul.bakker@luminis.eu> wrote:
> Should we maybe checkin the disabled baselining file for now until it works
> again?
>

+1 There are too much open issues and reports on this.

grz
Bram

>
> On Tue, Jul 29, 2014 at 10:49 AM, Marcel Offermans <
> marcel.offermans@luminis.eu> wrote:
>
>> Baselining currently does not work correctly in trunk.
>>
>> Go to cnf/ext/defaults.bnd and comment out the last line like this:
>>
>> # Semantic versioning
>> #-baseline: *
>>
>> That should "fix" the issue for now.
>> ________________________________________
>> From: Xu Zhidao <Zhidao.Xu@bosch-si.com>
>> Sent: Tuesday, July 29, 2014 9:09 AM
>> To: dev@ace.apache.org
>> Subject: Can not build ace trunk with command line.
>>
>> Hi,
>>
>> I get build error:
>>
>> Buildfile: ....\trunk\build\build.xml
>>
>> template.init:
>>      [echo] Enter project build
>>
>> init:
>>
>> dependencies:
>>
>> template.init:
>>      [echo] Enter project org.apache.ace.test
>>
>> init:
>>
>> dependencies:
>>
>> compile:
>>
>> build:
>>       [bnd] 1 Errors
>>       [bnd]  org.apache.ace.test:The bundle version 1.1.0 is too low, must
>> be at least 1.1.1
>>
>>
>> Regards
>>
>> Zhidao
>>
>> -----Original Message-----
>> From: Xu Zhidao [mailto:Zhidao.Xu@bosch-si.com]
>> Sent: Wednesday, June 04, 2014 12:42 PM
>> To: dev@ace.apache.org
>> Subject: Can not build after importing trunck to Eclipse 4.3.2 (BnDtools
>> and TestNG installed)
>>
>> Hi,
>>
>> I just follow the instruction of
>> http://ace.apache.org/dev-doc/getting-started.html to check out and
>> import, but get compilation errors in my Eclipse 4.3.2 (with Bndtools and
>> testNG).
>>
>> Some errors :
>>
>> Description         Resource             Path       Location
>> Type
>> The bundle version 1.0.1 is too low, must be at least 1.0.2
>> bnd.bnd               /org.apache.ace.client.rest         line 4
>>      Bndtools Problem Marker
>> The bundle version 2.0.0 is too low, must be at least 2.0.1
>> bnd.bnd               /org.apache.ace.builder               line 3
>>        Bndtools Problem Marker
>> The bundle version 1.0.1 is too low, must be at least 1.0.2
>> bnd.bnd               /org.apache.ace.agent  line 3     Bndtools Problem
>> Marker
>> The bundle version 1.0.0 is too low, must be at least 1.0.1
>> bnd.bnd               /org.apache.ace.client.workspace           line 3
>>          Bndtools Problem Marker
>> The bundle version 2.0.0 is too low, must be at least 2.0.1
>> bnd.bnd               /org.apache.ace.useradmin.ui   line 3
>>  Bndtools Problem Marker
>> The bundle version 1.0.1 is too low, must be at least 1.0.2
>> bnd.bnd               /org.apache.ace.consolelogger line 4
>>  Bndtools Problem Marker
>> The bundle version 1.0.1 is too low, must be at least 1.0.2
>> bnd.bnd               /org.apache.ace.target.mgmt.ui               line 4
>>            Bndtools Problem Marker
>> The bundle version 1.0.1 is too low, must be at least 1.0.2
>> bnd.bnd               /org.apache.ace.tageditor           line 4
>>      Bndtools Problem Marker
>> The bundle version 1.0.1 is too low, must be at least 1.0.2
>> bnd.bnd               /org.apache.ace.location.upnp  line 3
>>  Bndtools Problem Marker
>> The bundle version 1.0.1 is too low, must be at least 1.0.2
>> bnd.bnd               /org.apache.ace.webui.vaadin  line 6
>>  Bndtools Problem Marker
>> The bundle version 1.0.1 is too low, must be at least 1.0.2
>> bnd.bnd               /org.apache.ace.log.server.ui    line 4
>>  Bndtools Problem Marker
>> The bundle version 1.1.0 is too low, must be at least 1.1.1
>> bnd.bnd               /org.apache.ace.test      line 5     Bndtools Problem
>> Marker
>> The bundle version 1.1.0 is too low, must be at least 1.1.1
>> bnd.bnd               /org.apache.ace.range.api           line 3
>>      Bndtools Problem Marker
>> The bundle version 1.0.1 is too low, must be at least 1.0.2
>> bnd.bnd               /org.apache.ace.client.automation          line 4
>>          Bndtools Problem Marker
>> The bundle version 1.0.0 is too low, must be at least 1.0.1
>> bnd.bnd               /org.apache.ace.feedback.common       line 4
>>      Bndtools Problem Marker
>> The bundle version 2.0.0 is too low, must be at least 2.0.1
>> bnd.bnd                /org.apache.ace.resourceprocessor.useradmin line 6
>>   Bndtools Problem Marker
>>
>> I am new to osgi development, may I know what steps I missed for steup the
>> IDE?
>>
>> Regards
>>
>> Zhidao
>>
>>

Mime
View raw message