ace-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Xu Zhidao <Zhidao...@bosch-si.com>
Subject Can not build after importing trunck to Eclipse 4.3.2 (BnDtools and TestNG installed)
Date Wed, 04 Jun 2014 04:42:15 GMT
Hi,

I just follow the instruction of http://ace.apache.org/dev-doc/getting-started.html to check
out and import, but get compilation errors in my Eclipse 4.3.2 (with Bndtools and testNG).

Some errors :

Description         Resource             Path       Location               Type
The bundle version 1.0.1 is too low, must be at least 1.0.2             bnd.bnd          
    /org.apache.ace.client.rest         line 4                Bndtools Problem Marker
The bundle version 2.0.0 is too low, must be at least 2.0.1             bnd.bnd          
    /org.apache.ace.builder               line 3                Bndtools Problem Marker
The bundle version 1.0.1 is too low, must be at least 1.0.2             bnd.bnd          
    /org.apache.ace.agent  line 3     Bndtools Problem Marker
The bundle version 1.0.0 is too low, must be at least 1.0.1             bnd.bnd          
    /org.apache.ace.client.workspace           line 3              Bndtools Problem Marker
The bundle version 2.0.0 is too low, must be at least 2.0.1             bnd.bnd          
    /org.apache.ace.useradmin.ui   line 3                Bndtools Problem Marker
The bundle version 1.0.1 is too low, must be at least 1.0.2             bnd.bnd          
    /org.apache.ace.consolelogger line 4                Bndtools Problem Marker
The bundle version 1.0.1 is too low, must be at least 1.0.2             bnd.bnd          
    /org.apache.ace.target.mgmt.ui               line 4              Bndtools Problem Marker
The bundle version 1.0.1 is too low, must be at least 1.0.2             bnd.bnd          
    /org.apache.ace.tageditor           line 4                Bndtools Problem Marker
The bundle version 1.0.1 is too low, must be at least 1.0.2             bnd.bnd          
    /org.apache.ace.location.upnp  line 3                Bndtools Problem Marker
The bundle version 1.0.1 is too low, must be at least 1.0.2             bnd.bnd          
    /org.apache.ace.webui.vaadin  line 6                Bndtools Problem Marker
The bundle version 1.0.1 is too low, must be at least 1.0.2             bnd.bnd          
    /org.apache.ace.log.server.ui    line 4                Bndtools Problem Marker
The bundle version 1.1.0 is too low, must be at least 1.1.1             bnd.bnd          
    /org.apache.ace.test      line 5     Bndtools Problem Marker
The bundle version 1.1.0 is too low, must be at least 1.1.1             bnd.bnd          
    /org.apache.ace.range.api           line 3                Bndtools Problem Marker
The bundle version 1.0.1 is too low, must be at least 1.0.2             bnd.bnd          
    /org.apache.ace.client.automation          line 4              Bndtools Problem Marker
The bundle version 1.0.0 is too low, must be at least 1.0.1             bnd.bnd          
    /org.apache.ace.feedback.common       line 4              Bndtools Problem Marker
The bundle version 2.0.0 is too low, must be at least 2.0.1             bnd.bnd          
     /org.apache.ace.resourceprocessor.useradmin line 6     Bndtools Problem Marker

I am new to osgi development, may I know what steps I missed for steup the IDE?

Regards

Zhidao


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message