ace-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremias Maerki <...@jeremias-maerki.ch>
Subject Re: Client REST API
Date Thu, 03 Nov 2011 18:44:03 GMT
Thanks, Bram. I'm running the current Trunk and I've seen nothing that
would suggest the "Store" in the Vaadin client failed. I guess I'll have
to go debugging...

On 03.11.2011 17:18:05 Bram de Kruijff wrote:
> Hi Jeremias,
> 
> On Wed, Nov 2, 2011 at 12:02 PM, Jeremias Maerki <dev@jeremias-maerki.ch> wrote:
> > I'm currently experimenting with the Client REST API. I've pretty much
> > deciphered the API from the code now, but running some experiments with
> > curl, I don't get any results. Here's what I did:
> >
> > 1. Uploaded a couple of artifacts using the Vaadin interface and created
> > a feature with the two artifacts added to it. Clicked "Store".
> >
> > 2. POST http://localhost:8180/client/work
> >
> > -> Returns the session ID: Location: http://localhost:8180/client/work/rest-4
> >
> > 3. GET http://localhost:8180/client/work/rest-4/artifact
> >
> > -> Returns "[]"
> > (same for all other entity types)
> >
> > 4. DELETE http://localhost:8180/client/work/rest-4
> >
> > What am I missing?
> 
> Assuming the "Store" worked and thus a "Retrieve" yields the same
> state this should work. I just tried this against current trunk and it
> does work for me. Something fishy is going on...
> 
> happy hunting!
> Bram
> 
> > Thanks,
> > Jeremias Maerki
> >
> >




Jeremias Maerki


Mime
View raw message