ace-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcel Offermans <marcel.offerm...@luminis.nl>
Subject Re: Is there a configuration resourceprocessor?
Date Mon, 22 Aug 2011 07:54:17 GMT
Hello Bram,

On 18 Aug 2011, at 14:39 , Bram de Kruijff wrote:

> On Thu, Aug 18, 2011 at 10:59 AM, Angelo van der Sijpt
> <angelo.vandersijpt@luminis.eu> wrote:
>> The message you see tells us 'yes, we recognized your artifact, but we don't have
a resource processor bundle available.' During deployment, this bundle will be put into the
deployment package, and shipped along with the artifact so we can handle it (see section 114.10
of the OSGi Compendium spec).
>> 
>> You need to add a resource processor bundle to the system, just as you would import
any other bundle you want to provision (note that it will not be shown in the list of artifacts,
since it doesn't make sense to provision it yourself). There is an AutoConf processor available
as part of Felix' Deployment Admin.
> 
> Ok, that is easy enough. However, it seems they are not only hidden in
> the "provisioning UI" as I also do not seen them in the REST api.
> Feels very obscure. Is there any way to determine installed processors
> from a client perspective?

Not yet, which is why it's also not yet possible via the REST API. I agree we need to provide
a better mechanism for adding and maintaining resource processors, but see that as a separate
task. It's a little bit more involved than just adding a resource processor as well, as you
also need an accompanying artifact helper and recognizer (bundles that need to be added to
the ACE server itself, not the OBR).

> ps. Don't think this is documented anywhere on the site. Should I make
> jira issues for this stuff?

Yes, so we won't forget about it!

Greetings, Marcel


Mime
View raw message